summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 0 insertions, 24 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 97d885b..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-#
-# Hardening
-#
-export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-
-%:
- dh $@ --with autoreconf
-
-
-override_dh_installdocs:
- make -C doc doxygen-doc
- cp -r $(CURDIR)/doc/doxygen/html/* $(CURDIR)/debian/libpsocksxx-doc/usr/share/doc/libpsocksxx-doc/docs/
- dh_installdocs
-
-override_dh_makeshlibs:
- dpkg-gensymbols -plibpsocksxx0
- dh_makeshlibs
-