summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README.source18
-rw-r--r--debian/changelog25
-rw-r--r--debian/compat2
-rw-r--r--debian/control13
-rw-r--r--debian/copyright6
-rw-r--r--debian/libpsocksxx-doc.docs1
-rwxr-xr-xdebian/rules9
7 files changed, 59 insertions, 15 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..e4f2b3d
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,18 @@
+Hello,
+
+now I use the branching model from Vincent Driessen[1].
+
+I use the gitflow-avh[2]. with the Documentation[3].
+The Debian package can be found here[4].
+
+Please upload unattended uploads use a branch feature/<your title>.
+
+
+Many thanks.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Fri, 02 Jun 2017 19:00:40 +0200
+
+[1] http://nvie.com/posts/a-successful-git-branching-model/
+[2] https://github.com/petervanderdoes/gitflow-avh
+[3] https://github.com/petervanderdoes/gitflow-avh/wiki
+[4] https://tracker.debian.org/pkg/git-flow
diff --git a/debian/changelog b/debian/changelog
index eb664fc..4f555f7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,28 @@
+psocksxx (1.1.1-1) unstable; urgency=medium
+
+ * New upstream release.
+ * Migrate to debhelper 11:
+ - Change debian/compat to 11.
+ - Bump minimum debhelper version in debian/control to >= 11.
+ * Declare compliance with Debian Policy 4.1.5 (No changes needed).
+ * debian/control:
+ - Change to my new mail address.
+ - Switch Vcs-* to new location.
+ - Remove now default Build-Depends dh-autoreconf.
+ - Use secure URI for homepage.
+ * debian/copyright:
+ - Change to my new mail address.
+ - Use secure URI for copyright format.
+ - Add year 2018 for packaging.
+ * debian/rules:
+ - Remove now default --with autoreconf.
+ - Replace parsing the output of dpkg-parsechangelog with
+ $(DEB_VERSION_UPSTREAM).
+ * Remove debian/libpsocksxx-doc.docs to prevent twin install of README.md.
+ * New README.source to explain the branching model used.
+
+ -- Jörg Frings-Fürst <debian@jff.email> Tue, 10 Jul 2018 18:30:20 +0200
+
psocksxx (1.1.0-2) unstable; urgency=medium
* debian/control:
diff --git a/debian/compat b/debian/compat
index f599e28..b4de394 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-10
+11
diff --git a/debian/control b/debian/control
index d1a1c8a..df723c3 100644
--- a/debian/control
+++ b/debian/control
@@ -1,19 +1,18 @@
Source: psocksxx
Section: libs
Priority: optional
-Maintainer: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Maintainer: Jörg Frings-Fürst <debian@jff.email>
Uploaders: Uditha Atukorala <ua@nuked.zone>
Build-Depends:
- debhelper (>= 10),
- dh-autoreconf,
+ debhelper (>= 11),
libcunit1-dev,
libcppunit-dev
Build-Depends-Indep:
doxygen
-Standards-Version: 3.9.8
-Homepage: http://nukedzn.github.io/psocksxx
-Vcs-Git: git://anonscm.debian.org/collab-maint/psocksxx.git
-Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/psocksxx.git
+Standards-Version: 4.1.5
+Homepage: https://nukedzn.github.io/psocksxx
+Vcs-Git: git://jff.email/opt/git/psocksxx.git
+Vcs-Browser: https://jff.email/cgit/psocksxx.git/
Package: libpsocksxx0
Architecture: any
diff --git a/debian/copyright b/debian/copyright
index d29bcc9..2995e4c 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: psocksxx
Source: https://github.com/nukedzn/psocksxx
@@ -7,11 +7,11 @@ Copyright: 2013-2015 Uditha Atukorala <ua@nuked.zone>
License: LGPL-3+
Files: debian/*
-Copyright: 2014-2016 Jörg Frings-Fürst <debian@jff-webhosting.net>
+Copyright: 2014-2018 Jörg Frings-Fürst <debian@jff.email>
License: GPL-3+
Files: debian/patches/*
-Copyright: 2014-2016 Jörg Frings-Fürst <debian@jff-webhosting.net>
+Copyright: 2014-2018 Jörg Frings-Fürst <debian@jff.email>
License: LGPL-3+
License: LGPL-3+
diff --git a/debian/libpsocksxx-doc.docs b/debian/libpsocksxx-doc.docs
deleted file mode 100644
index b43bf86..0000000
--- a/debian/libpsocksxx-doc.docs
+++ /dev/null
@@ -1 +0,0 @@
-README.md
diff --git a/debian/rules b/debian/rules
index b8258ef..d42cda7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,10 +14,13 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
#
export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS) -Wall
-UPSTREAM_VERSION=$(shell dpkg-parsechangelog | sed -n '/\(Version:\)/{s/^Version:[[:space:]]\+\([0-9]\+:\)\?\(.*\)/\2/p}' | rev | cut -d- -f 2- | rev)
+#
+# for use $(DEB_ ...
+#
+include /usr/share/dpkg/default.mk
%:
- dh $@ --with autoreconf
+ dh $@
override_dh_auto_build-indep:
dh_auto_build
@@ -29,4 +32,4 @@ override_dh_installdocs-indep:
override_dh_makeshlibs:
dh_makeshlibs
- dpkg-gensymbols -v$(UPSTREAM_VERSION) -plibpsocksxx0
+ dpkg-gensymbols -v$(DEB_VERSION_UPSTREAM) -plibpsocksxx0