summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2019-07-31 16:59:49 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2019-07-31 16:59:49 +0200
commit1687222e1b9e74c89cafbb5910e72d8ec7bfd40f (patch)
treed78102ce30207c63e7608eeba743efd680c888dc /Makefile.am
parent58912f68c2489bcee787599837447e0d64dfd61a (diff)
New upstream version 1.0.28upstream/1.0.28
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 7 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index ae02ee3..54d0f27 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,7 +12,9 @@ dist_doc_DATA = AUTHORS ChangeLog COPYING LICENSE NEWS PROBLEMS PROJECTS \
README.hp-ux README.linux README.netbsd README.openbsd README.os2 \
README.solaris README.unixware2 README.unixware7 README.windows \
README.zeta
-EXTRA_DIST = $(PACKAGE).lsm
+
+EXTRA_DIST = .editorconfig
+EXTRA_DIST += po/README
#
# Keep the .gitignore files sorted, and use this target to do it.
@@ -68,24 +70,13 @@ libcheck:
installcheck-local:
cd testsuite && $(MAKE) test.local
-$(distdir).lsm: dist $(PACKAGE).lsm
- ( cat $(PACKAGE).lsm | \
- sed -e "s|_DATE_|`date +%d%b%y`|g" |\
- sed -e "s|_VERSION_|$(VERSION)|g" | \
- sed -e "s|_T_S_|`find $(distdir).tar.gz -printf "%4k"`|g" |\
- sed -e "s|_L_S_|`find $(PACKAGE).lsm -printf "%4k"`|g" >\
- $(distdir).lsm \
- )
-lsm: $(distdir).lsm
-
md5: dist
md5sum $(distdir).tar.gz > $(distdir).tar.gz.md5
-sane-backends: lsm md5
+sane-backends: md5
# Clean files created by custom targets in this file.
clean-local:
- rm -f sane-backends-*.lsm
rm -f $(distdir).tar.gz.md5
# Clean files created by configure
@@ -94,3 +85,6 @@ distclean-local:
rm -f include/byteorder.h
ACLOCAL_AMFLAGS = -I m4
+
+# Make potential issues stick out when running `make distcheck`.
+DISTCHECK_CONFIGURE_FLAGS = --enable-silent-rules