summaryrefslogtreecommitdiff
path: root/debian/patches/0015-frontend_libs.patch
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-10-13 07:21:57 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-10-13 07:21:57 +0200
commitbc7bfb103acda936bd145f2d90e292a5fe0460d2 (patch)
tree8f74d634be11840fd3f526e5fd48d94abbd7c26a /debian/patches/0015-frontend_libs.patch
parent90ad29d4f6fc7011a538a339bf3d4f9260899a80 (diff)
Rename & reorder patches
Diffstat (limited to 'debian/patches/0015-frontend_libs.patch')
-rw-r--r--debian/patches/0015-frontend_libs.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/patches/0015-frontend_libs.patch b/debian/patches/0015-frontend_libs.patch
new file mode 100644
index 0000000..31411bf
--- /dev/null
+++ b/debian/patches/0015-frontend_libs.patch
@@ -0,0 +1,33 @@
+From: Markus Koschany <apo@gambaru.de>
+Date: Sun, 30 Jun 2013 15:20:24 +0200
+Subject: frontend_libs
+
+Only link frontends against the libraries they need
+Reduce the dependencies on frontends by linking in only the required
+libraries.
+---
+ frontend/Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: trunk/frontend/Makefile.in
+===================================================================
+--- trunk.orig/frontend/Makefile.in
++++ trunk/frontend/Makefile.in
+@@ -238,7 +238,7 @@ LATEX = @LATEX@
+ LD = @LD@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = @LIBS@
++LIBS =
+ LIBTOOL = @LIBTOOL@
+ LIBUSB_1_0_CFLAGS = @LIBUSB_1_0_CFLAGS@
+ LIBUSB_1_0_LIBS = @LIBUSB_1_0_LIBS@
+@@ -365,7 +365,7 @@ scanimage_LDADD = ../backend/libsane.la
+
+ saned_SOURCES = saned.c
+ saned_LDADD = ../backend/libsane.la ../sanei/libsanei.la ../lib/liblib.la \
+- ../lib/libfelib.la @SYSLOG_LIBS@ @SYSTEMD_LIBS@
++ ../lib/libfelib.la @SYSLOG_LIBS@ @SYSTEMD_LIBS@ @AVAHI_LIBS@
+
+ test_SOURCES = test.c
+ test_LDADD = ../lib/liblib.la ../lib/libfelib.la ../backend/libsane.la