summaryrefslogtreecommitdiff
path: root/debian/patches/0125-multiarch_dll_search_path.patch
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-07 08:21:07 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-07 08:21:07 +0100
commit449bb3420bd6225876951dc8a76c5a2bd5139b5f (patch)
treea3a49b9911f81222861f421a19a0971bde8d2ee6 /debian/patches/0125-multiarch_dll_search_path.patch
parent1ecc4c25d9a91a6afe07a8b9c9b666f840ad6a0c (diff)
Undelete, refresh and rename 0125-multiarch_dll_search_path.patch
Diffstat (limited to 'debian/patches/0125-multiarch_dll_search_path.patch')
-rw-r--r--debian/patches/0125-multiarch_dll_search_path.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/debian/patches/0125-multiarch_dll_search_path.patch b/debian/patches/0125-multiarch_dll_search_path.patch
new file mode 100644
index 0000000..cc63bd6
--- /dev/null
+++ b/debian/patches/0125-multiarch_dll_search_path.patch
@@ -0,0 +1,46 @@
+Description: Keep /usr/lib/sane as a fallback for SANE backends
+ Make /usr/lib/arch_triplet/sane the default location for SANE backends,
+ but keep /usr/lib/sane as a fallback for now.
+Author: Julien BLACHE <jblache@debian.org>
+
+Index: trunk/backend/dll.c
+===================================================================
+--- trunk.orig/backend/dll.c
++++ trunk/backend/dll.c
+@@ -430,7 +430,7 @@ load (struct backend *be)
+
+ if (path)
+ {
+- src_len = strlen (path) + strlen (LIBDIR) + 1 + 1;
++ src_len = strlen (path) + strlen (DEB_DLL_LIBDIR) + 1 + 1;
+ src = malloc (src_len);
+ if (!src)
+ {
+@@ -438,12 +438,11 @@ load (struct backend *be)
+ return SANE_STATUS_NO_MEM;
+ }
+ orig_src = src;
+- snprintf (src, src_len, "%s:%s", path, LIBDIR);
++ snprintf (src, src_len, "%s:%s", path, DEB_DLL_LIBDIR);
+ }
+ else
+ {
+- src = LIBDIR;
+- src = strdup (src);
++ src = strdup (DEB_DLL_LIBDIR);
+ if (!src)
+ {
+ DBG (1, "load: strdup failed: %s\n", strerror (errno));
+Index: trunk/backend/Makefile.in
+===================================================================
+--- trunk.orig/backend/Makefile.in
++++ trunk/backend/Makefile.in
+@@ -1914,7 +1914,7 @@ target_alias = @target_alias@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-AM_CPPFLAGS = -I. -I$(srcdir) -I$(top_builddir)/include -I$(top_srcdir)/include -DLIBDIR="\"$(libdir)/sane\""
++AM_CPPFLAGS = -I. -I$(srcdir) -I$(top_builddir)/include -I$(top_srcdir)/include -DLIBDIR="$(libdir)/sane" -DDEB_DLL_LIBDIR="\"$(libdir)/sane:$(prefix)/lib/sane\""
+ AM_LDFLAGS = @STRICT_LDFLAGS@
+ # The -rpath option is added because we are creating _LTLIBRARIES based
+ # on configure substitution. This causes automake to not know the