summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-01-02 20:11:37 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-01-02 20:11:37 +0100
commit6023d0ffc729e956df760122594853ba6b3c4fa6 (patch)
treeeea93c0fcfe9a528bc8dd81a5b380b639e525d59 /debian/rules
parent6edba82e9f5b807d8d5aecc4139a64a211cb1b4e (diff)
Add version string to dpkg-gensymbols
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5fc4afb..3647468 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,6 +26,8 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
STRIP = ""
endif
+VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-/')
+
%:
dh $@ --parallel --with autotools_dev,systemd
@@ -137,5 +139,5 @@ override_dh_builddeb:
dh_builddeb -- -Zxz
override_dh_makeshlibs:
- dpkg-gensymbols -plibsane
+ dpkg-gensymbols -v$(VERSION) -plibsane
dh_makeshlibs