summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2019-04-28 10:24:29 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2019-04-28 10:24:29 +0200
commitbace12e994a5df9b013e8911429c805bf90317b2 (patch)
tree2a3268811384f85ea3af4c94a9b04d6c8c8c94e3 /debian/rules
parent7dd8a26724c9d51f5aebcf48370d12071b1c9ae1 (diff)
Fix the lintian warning libsane: package-name-doesnt-match-sonames libsane1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 1b57478..05d8b98 100755
--- a/debian/rules
+++ b/debian/rules
@@ -58,7 +58,7 @@ override_dh_auto_clean:
$(RM) include/byteorder.h include/_stdint.h
# Add here commands to clean up after the build process.
[ ! -f Makefile ] || $(MAKE) distclean
- $(RM) debian/libsane.udev
+ $(RM) debian/libsane1.udev
dh_auto_clean
override_dh_auto_install-arch:
@@ -113,9 +113,9 @@ override_dh_installudev-arch:
ifeq (linux,$(DEB_HOST_ARCH_OS))
# udev support
# Generate the udev rules file
- $(CURDIR)/tools/sane-desc -s $(CURDIR)/doc/descriptions -m udev+hwdb > $(CURDIR)/debian/libsane.udev
+ $(CURDIR)/tools/sane-desc -s $(CURDIR)/doc/descriptions -m udev+hwdb > $(CURDIR)/debian/libsane1.udev
$(CURDIR)/tools/sane-desc -s $(CURDIR)/doc/descriptions -m hwdb > $(CURDIR)/debian/20-sane.hwdb
- cp $(CURDIR)/debian/20-sane.hwdb $(CURDIR)/debian/libsane/lib/udev/hwdb.d/
+ cp $(CURDIR)/debian/20-sane.hwdb $(CURDIR)/debian/libsane1/lib/udev/hwdb.d/
dh_installudev
endif
@@ -132,4 +132,4 @@ override_dh_installsystemd-arch:
dh_installsystemd -psane-utils --no-enable --name=saned@
override_dh_makeshlibs-arch:
- dh_makeshlibs --exclude=/sane/ -- -v$(DEB_VERSION_UPSTREAM) -Pdebian/libsane -plibsane
+ dh_makeshlibs --exclude=/sane/ -- -v$(DEB_VERSION_UPSTREAM) -Pdebian/libsane1 -plibsane1