summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2021-04-30 19:51:20 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2021-04-30 19:51:20 +0200
commit57c64f1acca5b544b2f088097c7296649b7e122e (patch)
treed9bf7687989663a3875f363a5052be19361716ae /debian
parent93500879a52aa00d32bb85e0fa69bacea84c883c (diff)
Fix package doesn't purge cleanly (fix test with pathfind())
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/sane-utils.postrm4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 8483a9d..5c48515 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -38,6 +38,8 @@ sane-backends (1.0.32-1) UNRELEASED; urgency=medium
* debian/sane-utils.postrm:
- Fix package doesn't purge cleanly (user/group not purged)
(Closes: #987837).
+ - Fix package doesn't purge cleanly (fix test with pathfind())
+ (Closes: #987805).
-- Jörg Frings-Fürst <debian@jff.email> Tue, 16 Feb 2021 18:26:03 +0100
diff --git a/debian/sane-utils.postrm b/debian/sane-utils.postrm
index 20d95a7..30e2a2d 100644
--- a/debian/sane-utils.postrm
+++ b/debian/sane-utils.postrm
@@ -26,7 +26,7 @@ pathfind() {
if [ "$1" = purge ] ; then
- pathfind update-inetd || true
+ pathfind update-inetd
if [ $? = 0 ] ; then
update-inetd --remove sane-port || true
update-inetd --remove "#<off># sane-port" || true
@@ -54,7 +54,7 @@ if [ "$1" = purge ] ; then
#
# remove user / group
#
- pathfind deluser || true
+ pathfind deluser
if [ $? = 0 ] ; then
deluser -q --group --system saned || true
deluser -q --group --system scanner || true