summaryrefslogtreecommitdiff
path: root/frontend/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2021-05-18 07:43:35 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2021-05-18 07:43:35 +0200
commit9f8889f928ce86ba4a78659d378c6ba29bc9f735 (patch)
treec9567cb0d015b68ce3da8d03472b6443f1cb1ca9 /frontend/Makefile.am
parent446e9454b8cbe5b689149415d11d36e88442ca88 (diff)
parent154785ab2d5df7ddc8c2cf813b773c340e5e2aea (diff)
Merge branch 'release/debian/1.0.32-1'debian/1.0.32-1
Diffstat (limited to 'frontend/Makefile.am')
-rw-r--r--frontend/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/frontend/Makefile.am b/frontend/Makefile.am
index d27acf2..47c50f3 100644
--- a/frontend/Makefile.am
+++ b/frontend/Makefile.am
@@ -31,5 +31,18 @@ test_LDADD = ../lib/liblib.la ../backend/libsane.la
tstbackend_SOURCES = tstbackend.c
tstbackend_LDADD = ../lib/liblib.la ../backend/libsane.la
+if preloadable_backends_enabled
+if WITH_GENESYS_TESTS
+## Because the genesys backend is implemented in C++, programs need
+## to link against the standard C++ library. The work-around below
+## will work for the GNU C++ compiler with the GNU standard library
+## for C++. Other build scenarios may need work.
+scanimage_LDADD += -lstdc++
+saned_LDADD += -lstdc++
+test_LDADD += -lstdc++
+tstbackend_LDADD += -lstdc++
+endif
+endif
+
clean-local:
rm -f test tstbackend