summaryrefslogtreecommitdiff
path: root/debian/patches/0700-mk_reproducible_results.patch~
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0700-mk_reproducible_results.patch~')
-rw-r--r--debian/patches/0700-mk_reproducible_results.patch~154
1 files changed, 154 insertions, 0 deletions
diff --git a/debian/patches/0700-mk_reproducible_results.patch~ b/debian/patches/0700-mk_reproducible_results.patch~
new file mode 100644
index 0000000..044e60f
--- /dev/null
+++ b/debian/patches/0700-mk_reproducible_results.patch~
@@ -0,0 +1,154 @@
+Description: Make build reproducible.
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2019-08-11
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/tools/sane-desc.c
+===================================================================
+--- trunk.orig/tools/sane-desc.c
++++ trunk/tools/sane-desc.c
+@@ -2816,8 +2816,10 @@ html_print_footer (void)
+ "<address>\n"
+ "<a href=\"imprint.html\"\n"
+ ">Contact</a>\n" "</address>\n" "<font size=-1>\n");
+- printf ("This page was last updated on %s by sane-desc %s from %s\n",
+- asctime (localtime (&current_time)), SANE_DESC_VERSION, PACKAGE_STRING);
++/* printf ("This page was last updated on %s by sane-desc %s from %s\n",
++ asctime (localtime (&current_time)), SANE_DESC_VERSION, PACKAGE_STRING); */
++ printf ("This page was last updated by sane-desc %s from %s\n",
++ SANE_DESC_VERSION, PACKAGE_STRING);
+ printf ("</font>\n");
+ printf ("</body> </html>\n");
+ }
+@@ -3463,8 +3465,8 @@ print_udev_header (void)
+ {
+ time_t current_time = time (0);
+ printf ("# This file was automatically created based on description files (*.desc)\n"
+- "# by sane-desc %s from %s on %s",
+- SANE_DESC_VERSION, PACKAGE_STRING, asctime (localtime (&current_time)));
++ "# by sane-desc %s from %s\n",
++ SANE_DESC_VERSION, PACKAGE_STRING);
+
+ printf
+ ("#\n"
+@@ -3656,8 +3658,8 @@ print_udevhwdb_header (void)
+ {
+ time_t current_time = time (0);
+ printf ("# This file was automatically created based on description files (*.desc)\n"
+- "# by sane-desc %s from %s on %s",
+- SANE_DESC_VERSION, PACKAGE_STRING, asctime (localtime (&current_time)));
++ "# by sane-desc %s from %s\n",
++ SANE_DESC_VERSION, PACKAGE_STRING );
+
+ printf
+ ("#\n"
+Index: trunk/testsuite/tools/data/html-backends-split.ref
+===================================================================
+--- trunk.orig/testsuite/tools/data/html-backends-split.ref
++++ trunk/testsuite/tools/data/html-backends-split.ref
+@@ -16496,7 +16496,6 @@ Grandtek Scopecam
+ >Contact</a>
+ </address>
+ <font size=-1>
+-This page was last updated on Wed Jul 31 07:52:48 2013
+- by sane-desc 3.5 from sane-backends 1.0.24git
++This page was last updated by sane-desc 3.5 from sane-backends 1.0.28-debian
+ </font>
+ </body> </html>
+Index: trunk/testsuite/tools/data/html-mfgs.ref
+===================================================================
+--- trunk.orig/testsuite/tools/data/html-mfgs.ref
++++ trunk/testsuite/tools/data/html-mfgs.ref
+@@ -23910,7 +23910,6 @@ qcam<br>(unmaintained)
+ >Contact</a>
+ </address>
+ <font size=-1>
+-This page was last updated on Wed Jul 31 07:52:48 2013
+- by sane-desc 3.5 from sane-backends 1.0.24git
++This page was last updated by sane-desc 3.5 from sane-backends 1.0.28-debian
+ </font>
+ </body> </html>
+Index: trunk/testsuite/tools/data/udev.ref
+===================================================================
+--- trunk.orig/testsuite/tools/data/udev.ref
++++ trunk/testsuite/tools/data/udev.ref
+@@ -1,5 +1,5 @@
+ # This file was automatically created based on description files (*.desc)
+-# by sane-desc 3.5 from sane-backends 1.0.24git on Wed Jul 31 07:52:48 2013
++# by sane-desc 3.5 from sane-backends 1.0.28-debian
+ #
+ # udev rules file for supported USB and SCSI devices
+ #
+Index: trunk/testsuite/tools/data/udev+acl.ref
+===================================================================
+--- trunk.orig/testsuite/tools/data/udev+acl.ref
++++ trunk/testsuite/tools/data/udev+acl.ref
+@@ -1,5 +1,5 @@
+ # This file was automatically created based on description files (*.desc)
+-# by sane-desc 3.5 from sane-backends 1.0.24git on Wed Jul 31 07:52:49 2013
++# by sane-desc 3.5 from sane-backends 1.0.28-debian
+ #
+ # udev rules file for supported USB and SCSI devices
+ #
+Index: trunk/testsuite/tools/data/udev+hwdb.ref
+===================================================================
+--- trunk.orig/testsuite/tools/data/udev+hwdb.ref
++++ trunk/testsuite/tools/data/udev+hwdb.ref
+@@ -1,5 +1,5 @@
+ # This file was automatically created based on description files (*.desc)
+-# by sane-desc 3.5 from sane-backends 1.0.24git on Thu Aug 1 18:50:15 2013
++# by sane-desc 3.5 from sane-backends 1.0.28-debian
+ #
+ # udev rules file for supported USB and SCSI devices
+ #
+Index: trunk/doc/Makefile.am
+===================================================================
+--- trunk.orig/doc/Makefile.am
++++ trunk/doc/Makefile.am
+@@ -278,11 +278,11 @@ sane.ind: $(API_SPEC_INPUTS)
+
+ sane.dvi: $(API_SPEC_INPUTS) $(API_SPEC_EPS_FIGS) sane.ind
+ @echo Generating $@ from $<...
+- @$(am_TEXINPUTS) $(LATEX) $< </dev/null >/dev/null
++ @$(am_TEXINPUTS) $(LATEX) --output-comment="" $< </dev/null >/dev/null
+
+ sane.ps: sane.dvi
+ @echo Generating $@ from $<...
+- @$(am_TEXINPUTS) $(DVIPS) -q $< -o $@
++ @$(am_TEXINPUTS) $(DVIPS) -q -N $< -o $@
+
+ .fig.pdf:
+ @test -d $(@D) || $(MKDIR_P) $(@D)
+Index: trunk/testsuite/tools/data/db.ref
+===================================================================
+--- trunk.orig/testsuite/tools/data/db.ref
++++ trunk/testsuite/tools/data/db.ref
+@@ -1,5 +1,5 @@
+ # This file was automatically created based on description files (*.desc)
+-# by sane-desc 3.5 from sane-backends 1.0.24git on Wed Jul 31 07:52:48 2013
++# by sane-desc 3.5 from sane-backends 1.0.28-debian
+ #
+ # The entries below are used to detect a USB device when it's plugged in
+ # and then run a script to change the ownership and
+Index: trunk/testsuite/tools/data/hwdb.ref
+===================================================================
+--- trunk.orig/testsuite/tools/data/hwdb.ref
++++ trunk/testsuite/tools/data/hwdb.ref
+@@ -1,5 +1,5 @@
+ # This file was automatically created based on description files (*.desc)
+-# by sane-desc 3.5 from sane-backends 1.0.25git on Tue Dec 3 15:24:46 2013
++# by sane-desc 3.5 from sane-backends 1.0.28-debian
+ #
+ # hwdb file for supported USB devices
+ #
+Index: trunk/testsuite/tools/data/usermap.ref
+===================================================================
+--- trunk.orig/testsuite/tools/data/usermap.ref
++++ trunk/testsuite/tools/data/usermap.ref
+@@ -1,5 +1,5 @@
+ # This file was automatically created based on description files (*.desc)
+-# by sane-desc 3.5 from sane-backends 1.0.24git on Wed Jul 31 07:52:48 2013
++# by sane-desc 3.5 from sane-backends 1.0.28-debian
+ #
+ # The entries below are used to detect a USB device and change owner
+ # and permissions on the "device node" used by libusb.