summaryrefslogtreecommitdiff
path: root/testsuite/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuite/tools/Makefile.am')
-rw-r--r--testsuite/tools/Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/testsuite/tools/Makefile.am b/testsuite/tools/Makefile.am
index 532e904..5fd97ca 100644
--- a/testsuite/tools/Makefile.am
+++ b/testsuite/tools/Makefile.am
@@ -28,19 +28,25 @@ check: check.local
check.local:
@echo "**** Testing $(SANEDESC) with $(TESTFILE)"
- @for mode in ascii html-backends-split html-mfgs xml statistics usermap db udev udev+acl udev+hwdb hwdb plist hal hal-new; \
+ @pass=true; \
+ for mode in ascii html-backends-split html-mfgs xml statistics usermap db udev udev+acl udev+hwdb hwdb plist hal hal-new; \
do \
$(SANEDESC) -m $$mode -s $(srcdir)/data >$$mode.res ;\
- if diff -I "[ 012][0-9]:[0-5][0-9]:[0-6][0-9] 20[0-9][0-9]" \
- -I "sane-backends 1\.0\.[0-9]\+\([-0-9a-fgdirty]\+\)\?$$" \
+ if diff -I "sane-backends 1\.0\.[0-9]\+\([-0-9a-fgdirty]\+\)\?$$" \
$(srcdir)/data/$$mode.ref $$mode.res ; \
then \
echo "PASS: sane-desc -m $$mode -s $(srcdir)/data"; \
else \
echo "FAIL: sane-desc -m $$mode -s $(srcdir)/data"; \
- exit 1 ;\
+ pass=false ; \
fi; \
done ;\
- echo "================" ;\
- echo "All tests passed" ;\
- echo "================"
+ if `$$pass`; then \
+ echo "================" ; \
+ echo "All tests passed" ; \
+ echo "================" ; \
+ else \
+ echo "========================" ; \
+ echo "One or more tests failed" ; \
+ echo "========================" ; \
+ fi