summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules100
1 files changed, 0 insertions, 100 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 2db7de8..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,100 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# Include dpatch rules
-include /usr/share/dpatch/dpatch.make
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -g
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-autotools: autotools-stamp
-autotools-stamp:
- rm -f config.sub config.guess
- ln -s /usr/share/misc/config.sub config.sub
- ln -s /usr/share/misc/config.guess config.guess
- touch autotools-stamp
-
-config.status: autotools-stamp configure
- dh_testdir
- # Add here commands to configure the package.
- ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info --datadir=\$${prefix}/share
-
-build: build-stamp
-build-stamp: patch-stamp config.status
- dh_testdir
-
- # Add here commands to compile the package.
- $(MAKE)
-
- touch build-stamp
-
-clean: real-clean unpatch
-real-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp autotools-stamp
-
- # Add here commands to clean up after the build process.
- [ ! -f Makefile ] || $(MAKE) distclean
-
- rm -f config.sub config.guess
-
- dh_clean
-
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/sane
- $(MAKE) install prefix=$(CURDIR)/debian/sane/usr
-
- cp $(CURDIR)/debian/xscanimage-icon-32x32-2.xpm $(CURDIR)/debian/sane/usr/share/sane
-
-# Build architecture-independent files here.
-binary-indep:
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installdocs
-# dh_installexamples
- dh_installmenu
- dh_installman
-# dh_installinfo
-# dh_undocumented
- dh_installchangelogs Changelog
- dh_link usr/bin/xscanimage usr/lib/gimp/2.0/plug-ins/xscanimage
- dh_strip
- dh_compress
- dh_fixperms
-# dh_makeshlibs
- dh_installdeb
-# dh_perl
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install patch unpatch real-clean autotools