summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules47
1 files changed, 47 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..be45bc1
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,47 @@
+#!/usr/bin/make -f
+
+VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-/')
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ db2html -o ${CURDIR}/user doc/user/main.xml || true
+ db2html -o ${CURDIR}/user -u doc/user/main.xml || true
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -fr build-stamp docbook2html-dir user
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+binary-indep: install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installchangelogs
+ dh_link usr/share/doc/scons-doc/user/main.html usr/share/doc/scons-doc/user.html
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary-arch: install
+
+binary: binary-indep binary-arch
+
+get-orig-source:
+ svn co http://scons.tigris.org/svn/scons/tags/${VERSION} scons-${VERSION} --username guest --password ""
+ tar czf ../scons-doc_${VERSION}.orig.tar.gz --exclude=.svn scons-${VERSION}/LICENSE scons-${VERSION}/doc
+ rm -fr scons-${VERSION}
+
+.PHONY: build clean binary-indep binary-arch binary install get-orig-source
+