summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README.source18
-rw-r--r--debian/changelog14
-rw-r--r--debian/control6
-rw-r--r--debian/copyright4
-rw-r--r--debian/files2
-rw-r--r--debian/patches/0001-user_guide.patch4
-rwxr-xr-xdebian/repack.sh50
-rw-r--r--debian/watch1
8 files changed, 40 insertions, 59 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..e4f2b3d
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,18 @@
+Hello,
+
+now I use the branching model from Vincent Driessen[1].
+
+I use the gitflow-avh[2]. with the Documentation[3].
+The Debian package can be found here[4].
+
+Please upload unattended uploads use a branch feature/<your title>.
+
+
+Many thanks.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Fri, 02 Jun 2017 19:00:40 +0200
+
+[1] http://nvie.com/posts/a-successful-git-branching-model/
+[2] https://github.com/petervanderdoes/gitflow-avh
+[3] https://github.com/petervanderdoes/gitflow-avh/wiki
+[4] https://tracker.debian.org/pkg/git-flow
diff --git a/debian/changelog b/debian/changelog
index ec9379d..57ba688 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+scons-doc (3.0.0+repack-1) unstable; urgency=medium
+
+ * New upstream release.
+ - Refresh patches:
+ + patches/0001-user_guide.patch.
+ * New README.source to explain the branching model used.
+ * Declare compliance with Debian Policy 4.1.0. (No changes needed).
+ * debian/copyright:
+ - Add year 2017.
+ - Move the repack without unwanted files from repack.sh into
+ copyright Files-Excluded.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 01 Oct 2017 13:43:25 +0200
+
scons-doc (2.5.1+repack-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index 37343f1..bd0f649 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Jörg Frings-Fürst <debian@jff-webhosting.net>
Uploaders: Laszlo Boszormenyi (GCS) <gcs@debian.org>
Build-Depends:
debhelper (>= 10),
- scons (>= 2.5)
+ scons (>= 3.0)
Build-Depends-Indep:
openjdk-8-jre,
docbook-utils,
@@ -13,7 +13,7 @@ Build-Depends-Indep:
fop,
python-libxml2,
python-libxslt1
-Standards-Version: 3.9.8
+Standards-Version: 4.1.0
Homepage: https://www.scons.org/
Vcs-Git: https://anonscm.debian.org/cgit/collab-maint/scons-doc.git
Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/scons-doc.git
@@ -21,7 +21,7 @@ Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/scons-doc.git
Package: scons-doc
Architecture: all
Depends: ${misc:Depends}
-Suggests: scons (>= 2.5)
+Suggests: scons (>= 3.0)
Description: Documentation for SCons, a replacement for Make
SCons is a make replacement providing a range of enhanced features such
as automated dependency generation and built in compilation cache
diff --git a/debian/copyright b/debian/copyright
index 1541ac5..e964123 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -18,7 +18,7 @@ Files-Excluded: HOWTO
runtest.py
Files: *
-Copyright: 2001-2016 The SCons Foundation
+Copyright: 2001-2017 The SCons Foundation
1999-2006 Gregory P. Ward
2001-2003 Steven Knight
2001-2004 Twisted Matrix Laboratories
@@ -31,7 +31,7 @@ Files: doc/user/titlepage/SConsBuildBricks_path.svg
doc/design/titlepage/SConsBuildBricks_path.svg
doc/man/titlepage/SConsBuildBricks_path.svg
doc/reference/titlepage/SConsBuildBricks_path.svg
-Copyright: 2001-2016 The SCons Foundation
+Copyright: 2001-2017 The SCons Foundation
1999-2006 Gregory P. Ward
2001-2003 Steven Knight
2001-2004 Twisted Matrix Laboratories
diff --git a/debian/files b/debian/files
index 58c551f..d209510 100644
--- a/debian/files
+++ b/debian/files
@@ -1 +1 @@
-scons-doc_2.5.1+repack-1_source.buildinfo doc optional
+scons-doc_3.0.0+repack-1_source.buildinfo doc optional
diff --git a/debian/patches/0001-user_guide.patch b/debian/patches/0001-user_guide.patch
index 4d608d1..88a718a 100644
--- a/debian/patches/0001-user_guide.patch
+++ b/debian/patches/0001-user_guide.patch
@@ -8,7 +8,7 @@ Index: trunk/doc/SConscript
===================================================================
--- trunk.orig/doc/SConscript
+++ trunk/doc/SConscript
-@@ -308,12 +308,12 @@ else:
+@@ -311,12 +311,12 @@ else:
DOCTARGETS = 0
DOCDEPENDS = 1
DOCNODES = 2
@@ -22,5 +22,5 @@ Index: trunk/doc/SConscript
- 'man' : (['man','epub','text'], [], [])
+ #'man' : (['man','epub','text'], [], [])
}
-
+
#
diff --git a/debian/repack.sh b/debian/repack.sh
deleted file mode 100755
index 233dea5..0000000
--- a/debian/repack.sh
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/sh -e
-# Repackaging script to be called by Uscan
-
-echo "Repackaging ..."
-TMP="../"
-PKG="`dpkg-parsechangelog|sed 's/^Source: //p;d'`_$2+repack.orig"
-
-
-echo "Extracting tarball ..."
-tar xzf "$3" -C "$TMP"
-cd "$TMP"
-
-echo "Rename source dir"
-#ls -l
-mv scons-src-$2 scons-doc-$2
-
-echo "Removing unwanted stuff ..."
-cd scons-doc-$2
-#mv scons-src-$2 scons-doc-$2
-#cd scons-doc-$2
-ls -l
-rm -rf HOWTO
-rm -rf debian
-rm -rf bench
-rm -rf examples
-rm -rf gentoo
-rm -rf rpm
-rm -rf template
-rm -rf test
-rm -rf testing
-rm -rf timings
-rm -rf .hgtags
-rm -rf *-local
-rm -rf ReleaseConfig
-rm -rf runtest.py
-ls -l
-#cd ..
-
-echo "Creating repack tarball ..."
-tar -caf "../scons-doc_$2+repack.orig.tar.xz" *
-
-cd ..
-echo "Clean tmp dir ..."
-rm -rf scons-doc-$2
-
-echo "Clean uscan files ..."
-rm -rf scons-src-2.3.5.tar.gz
-rm -rf scons-doc_2.3.5.orig.tar.gz
-
-echo "Repackaged tarball created"
diff --git a/debian/watch b/debian/watch
index 3f0e004..0208447 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,4 +1,3 @@
version=4
opts=dversionmangle=s/\+repack(.*)// \
http://sf.net/scons/scons-src-(\d\S*)\.(?:tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz)))
-# debian debian/repack.sh