summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py51
1 files changed, 28 insertions, 23 deletions
diff --git a/setup.py b/setup.py
index f4a08c3..922aee4 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2001 - 2017 The SCons Foundation
+# Copyright (c) 2001 - 2019 The SCons Foundation
#
# Permission is hereby granted, free of charge, to any person obtaining
# a copy of this software and associated documentation files (the
@@ -20,6 +20,17 @@
# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+from __future__ import print_function
+
+
+import distutils.command.build_scripts
+import distutils.command.install_scripts
+import distutils.command.install_lib
+import distutils.command.install_data
+import distutils.command.install
+import distutils.core
+import distutils
+# import setuptools
"""
NOTE: Installed SCons is not importable like usual Python packages. It is
executed explicitly with command line scripts. This allows multiple
@@ -32,15 +43,14 @@ NOTE: Installed SCons is not importable like usual Python packages. It is
below is dedicated to make it happen on various platforms.
"""
-from __future__ import print_function
-__revision__ = "src/setup.py 74b2c53bc42290e911b334a6b44f187da698a668 2017/11/14 13:16:53 bdbaddog"
+__revision__ = "src/setup.py 72ae09dc35ac2626f8ff711d8c4b30b6138e08e3 2019-08-08 14:50:06 bdeegan"
import os
import stat
import sys
-Version = "3.0.1"
+Version = "3.1.1"
man_pages = [
'scons.1',
@@ -66,15 +76,6 @@ if not sys.platform == 'win32':
else:
is_win32 = 1
-import distutils
-import distutils.core
-import distutils.command.install
-import distutils.command.install_data
-import distutils.command.install_lib
-import distutils.command.install_scripts
-import distutils.command.build_scripts
-import distutils.msvccompiler
-
_install = distutils.command.install.install
_install_data = distutils.command.install_data.install_data
@@ -165,7 +166,7 @@ class install(_install):
self.no_scons_script = 0
self.no_version_script = 0
self.install_bat = 0
- self.no_install_bat = not is_win32
+ self.no_install_bat = False # not is_win32
self.install_man = 0
self.no_install_man = is_win32
self.standard_lib = 0
@@ -247,10 +248,12 @@ class install_lib(_install_lib):
if Options.standalone_lib:
# ...but they asked for a standalone directory.
self.install_dir = os.path.join(prefix, "scons")
- elif Options.version_lib or not Options.standard_lib:
+ elif Options.version_lib:
# ...they asked for a version-specific directory,
- # or they get it by default.
self.install_dir = os.path.join(prefix, "scons-%s" % Version)
+ elif not Options.standard_lib:
+ # default.
+ self.install_dir = os.path.join(prefix, "scons")
msg = "Installed SCons library modules into %s" % self.install_dir
Installed.append(msg)
@@ -323,8 +326,8 @@ class install_scripts(_install_scripts):
scons = os.path.join(self.install_dir, base)
scons_ver = scons + '-' + Version
if is_win32:
- scons += '.py'
- scons_ver += '.py'
+ scons = scons + '.py'
+ scons_ver = scons_ver + '.py'
create_version_script(src, scons_ver)
create_basename_script(src, scons, scons_ver)
@@ -352,7 +355,8 @@ class install_scripts(_install_scripts):
# Use symbolic versions of permissions so this script doesn't fail to parse under python3.x
exec_and_read_permission = stat.S_IXOTH | stat.S_IXUSR | stat.S_IXGRP | stat.S_IROTH | stat.S_IRUSR | stat.S_IRGRP
mode_mask = 4095 # Octal 07777 used because python3 has different octal syntax than python 2
- mode = ((os.stat(file)[stat.ST_MODE]) | exec_and_read_permission) & mode_mask
+ mode = ((os.stat(file)[stat.ST_MODE]) |
+ exec_and_read_permission) & mode_mask
# log.info("changing mode of %s to %o", file, mode)
os.chmod(file, mode)
# --- /distutils copy/paste ---
@@ -410,18 +414,19 @@ arguments = {
'version': Version,
'description': description,
'long_description': long_description,
- 'author': 'Steven Knight',
- 'author_email': 'knight@baldmt.com',
+ 'author': 'William Deegan',
+ 'author_email': 'bill@baddogconsulting.com',
'url': "http://www.scons.org/",
'packages': ["SCons",
"SCons.compat",
"SCons.Node",
- "SCons.Options",
"SCons.Platform",
"SCons.Scanner",
"SCons.Script",
"SCons.Tool",
+ "SCons.Tool.clangCommon",
"SCons.Tool.docbook",
+ 'SCons.Tool.clangCommon',
"SCons.Tool.MSCommon",
"SCons.Tool.packaging",
"SCons.Variables",
@@ -502,7 +507,7 @@ arguments = {
'install_lib': install_lib,
'install_data': install_data,
'install_scripts': install_scripts,
- 'build_scripts': build_scripts}
+ 'build_scripts': build_scripts},
}
distutils.core.setup(**arguments)