summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 2 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 7a2b84a..f4a08c3 100644
--- a/setup.py
+++ b/setup.py
@@ -34,13 +34,13 @@ NOTE: Installed SCons is not importable like usual Python packages. It is
from __future__ import print_function
-__revision__ = "src/setup.py rel_3.0.0:4395:8972f6a2f699 2017/09/18 12:59:24 bdbaddog"
+__revision__ = "src/setup.py 74b2c53bc42290e911b334a6b44f187da698a668 2017/11/14 13:16:53 bdbaddog"
import os
import stat
import sys
-Version = "3.0.0"
+Version = "3.0.1"
man_pages = [
'scons.1',
@@ -76,16 +76,6 @@ import distutils.command.build_scripts
import distutils.msvccompiler
-def get_build_version():
- """ monkey patch distutils msvc version if we're not on windows.
- We need to use vc version 9 for python 2.7.x and it defaults to 6
- for non-windows platforms and there is no way to override it besides
- monkey patching"""
- return 9
-
-
-distutils.msvccompiler.get_build_version = get_build_version
-
_install = distutils.command.install.install
_install_data = distutils.command.install_data.install_data
_install_lib = distutils.command.install_lib.install_lib