summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-06-05 10:20:24 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-06-05 10:20:24 +0200
commit6d0ad872b67aa8632f7bb41009ae76816a52421c (patch)
tree4fe935e2c65c34a9b9479c9bbf3990be2d594e53 /debian/patches
parentbec5f87053759705fb77bae1aa378f2666c7d153 (diff)
renew patches; make build reproducible
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-buildflags.patch15
-rw-r--r--debian/patches/0005-hardening.patch12
-rw-r--r--debian/patches/0100-ios8.patch10
-rw-r--r--debian/patches/series8
4 files changed, 16 insertions, 29 deletions
diff --git a/debian/patches/0001-buildflags.patch b/debian/patches/0001-buildflags.patch
index a8030ec..9b293f4 100644
--- a/debian/patches/0001-buildflags.patch
+++ b/debian/patches/0001-buildflags.patch
@@ -7,20 +7,7 @@ Index: trunk/Makefile
===================================================================
--- trunk.orig/Makefile
+++ trunk/Makefile
-@@ -395,10 +395,11 @@ VALA_CFLAGS := `pkg-config --cflags $(EX
- $(foreach def,$(DEFINES),-D$(def))
-
- VALA_LDFLAGS := `pkg-config --libs $(EXT_PKGS) $(DIRECT_LIBS) gthread-2.0`
-+VALA_LDFLAGS += -fPIE -pie -Wl,-z,relro -Wl,-z,now
-
- # REQUIRED_CFLAGS absolutely get appended to CFLAGS, whatever the
- # the value of CFLAGS in the environment
--REQUIRED_CFLAGS := -fPIC
-+REQUIRED_CFLAGS := -g -O2 -fPIE -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2
-
- # setting CFLAGS in configure.mk overrides build type
- ifndef CFLAGS
-@@ -411,8 +412,8 @@ PLUGIN_CFLAGS = -O2 -g -pipe
+@@ -403,8 +403,8 @@ PLUGIN_CFLAGS = -O2 -g -pipe
endif
endif
diff --git a/debian/patches/0005-hardening.patch b/debian/patches/0005-hardening.patch
index c60496f..0ace20c 100644
--- a/debian/patches/0005-hardening.patch
+++ b/debian/patches/0005-hardening.patch
@@ -14,7 +14,7 @@ Index: trunk/Makefile
ifdef UNITY_SUPPORT
VALAFLAGS := $(VALAFLAGS) --define UNITY_SUPPORT
endif
-@@ -673,7 +673,7 @@ $(EXPANDED_C_FILES): $(VALA_STAMP)
+@@ -677,7 +677,7 @@ $(EXPANDED_C_FILES): $(VALA_STAMP)
@
$(EXPANDED_OBJ_FILES): %.o: %.c $(CONFIG_IN) Makefile
@@ -27,12 +27,12 @@ Index: trunk/plugins/Makefile.plugin.mk
===================================================================
--- trunk.orig/plugins/Makefile.plugin.mk
+++ trunk/plugins/Makefile.plugin.mk
-@@ -41,7 +41,7 @@ DEFINES := -D_VERSION='"$(PLUGINS_VERSIO
+@@ -42,7 +42,7 @@ DEFINES := -D_VERSION='"$(PLUGINS_VERSIO
all: $(PLUGIN).so
.stamp: $(SRC_FILES) $(MAKE_FILES) $(HEADER_FILES)
-- $(VALAC) --target-glib=$(MIN_GLIB_VERSION) -g --enable-checking --fatal-warnings --save-temps --compile --enable-deprecated \
-+ $(VALAC) --target-glib=$(MIN_GLIB_VERSION) -g --enable-checking --save-temps --compile --enable-deprecated \
+- $(VALAC) --target-glib=$(MIN_GLIB_VERSION) -g --enable-checking --fatal-warnings --ccode --enable-deprecated \
++ $(VALAC) --target-glib=$(MIN_GLIB_VERSION) -g --enable-checking --ccode --enable-deprecated \
--vapidir=../ $(foreach pkg,$(PKGS),--pkg=$(pkg)) $(foreach pkg,$(CUSTOM_VAPI_PKGS),--pkg=$(pkg)) \
- -X -I../.. -X -fPIC \
- $(foreach dfn,$(DEFINES),-X $(dfn)) \
+ $(USER_VALAFLAGS) \
+ --vapidir=../../vapi \
diff --git a/debian/patches/0100-ios8.patch b/debian/patches/0100-ios8.patch
index f6f4594..f438dde 100644
--- a/debian/patches/0100-ios8.patch
+++ b/debian/patches/0100-ios8.patch
@@ -9,7 +9,7 @@ Index: trunk/src/camera/ImportPage.vala
===================================================================
--- trunk.orig/src/camera/ImportPage.vala
+++ trunk/src/camera/ImportPage.vala
-@@ -766,6 +766,15 @@ public class ImportPage : CheckerboardPa
+@@ -765,6 +765,15 @@ public class ImportPage : CheckerboardPa
~ImportPage() {
LibraryPhoto.global.contents_altered.disconnect(on_media_added_removed);
Video.global.contents_altered.disconnect(on_media_added_removed);
@@ -25,7 +25,7 @@ Index: trunk/src/camera/ImportPage.vala
}
public override Gtk.Toolbar get_toolbar() {
-@@ -1153,11 +1162,14 @@ public class ImportPage : CheckerboardPa
+@@ -1152,11 +1161,14 @@ public class ImportPage : CheckerboardPa
update_status(busy, false);
refresh_error = null;
@@ -45,7 +45,7 @@ Index: trunk/src/camera/ImportPage.vala
}
update_status(true, refreshed);
-@@ -1262,13 +1274,15 @@ public class ImportPage : CheckerboardPa
+@@ -1261,13 +1273,15 @@ public class ImportPage : CheckerboardPa
progress_bar.set_ellipsize(Pango.EllipsizeMode.NONE);
progress_bar.set_text("");
progress_bar.set_fraction(0.0);
@@ -63,7 +63,7 @@ Index: trunk/src/camera/ImportPage.vala
if (refresh_result == GPhoto.Result.OK) {
update_status(false, true);
} else {
-@@ -1634,11 +1648,15 @@ public class ImportPage : CheckerboardPa
+@@ -1633,11 +1647,15 @@ public class ImportPage : CheckerboardPa
}
private void import(Gee.Iterable<DataObject> items) {
@@ -84,7 +84,7 @@ Index: trunk/src/camera/ImportPage.vala
}
update_status(true, refreshed);
-@@ -1774,12 +1792,15 @@ public class ImportPage : CheckerboardPa
+@@ -1773,12 +1791,15 @@ public class ImportPage : CheckerboardPa
}
private void close_import() {
diff --git a/debian/patches/series b/debian/patches/series
index fe75c5e..44fcb41 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,8 +1,8 @@
0001-buildflags.patch
0005-hardening.patch
0010-libexec.patch
-0500-Port-to-webkit2gtk-40.patch
-0501-Dont-pack-webview-into-a-scrolled-window.patch
-0502-Have-all-soup-sessions-validate-TLS-certificates.patch
-0503-facebook-Dont-disable-XSS-auditor.patch
+#0500-Port-to-webkit2gtk-40.patch
+#0501-Dont-pack-webview-into-a-scrolled-window.patch
+#0502-Have-all-soup-sessions-validate-TLS-certificates.patch
+#0503-facebook-Dont-disable-XSS-auditor.patch
0100-ios8.patch