summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2022-04-05 17:14:18 +0200
committerJörg Frings-Fürst <debian@jff.email>2022-04-05 17:14:18 +0200
commit4c548cd33f0614e666d9049e41b4f129629cf182 (patch)
treebaa900ff37979f45c28841af16b79aa7f2a69a3b /meson.build
parent2ed34746222ea505631ae8ef8ca50552af999ad2 (diff)
New upstream version 0.30.15upstream/0.30.15
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 6 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index a2db302..a5f9061 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project('shotwell', ['vala', 'c'],
- version : '0.30.14',
+ version : '0.30.15',
meson_version : '>= 0.43.0',
default_options : ['buildtype=debugoptimized'])
@@ -20,7 +20,8 @@ vapi_incdir = include_directories('vapi')
shotwell_plugin_dir = join_paths(get_option('libdir'), 'shotwell', 'plugins', 'builtin')
add_global_arguments(['-DHAVE_CONFIG_H=1'],
- ['-include'], ['config.h'], language : 'c')
+ ['-include'], ['config.h'],
+ language : 'c')
add_global_arguments(['--target-glib=2.40',
'--vapidir=@0@'.format(join_paths(meson.current_source_dir(),
'vapi')),
@@ -28,6 +29,8 @@ add_global_arguments(['--target-glib=2.40',
'--enable-experimental',
'--enable-deprecated'], language : 'vala')
+version_h = vcs_tag(command: ['git', 'rev-parse', 'HEAD'], input: 'version.h.in', output: 'version.h', fallback: '')
+version = declare_dependency(sources : version_h, include_directories : include_directories('.'))
if get_option('fatal_warnings')
add_global_arguments(
[
@@ -37,12 +40,6 @@ if get_option('fatal_warnings')
)
endif
-gitver = run_command(find_program('git-hash'))
-if gitver.returncode() == 0
- add_global_arguments(['-D_GIT_VERSION="@0@"'.format(gitver.stdout().strip())],
- language : 'c')
- add_global_arguments(['--define=_GITVERSION'], language : 'vala')
-endif
gtk = dependency('gtk+-3.0', version : '>= 3.22')
gio = dependency('gio-2.0', version: '>= 2.40')
@@ -67,6 +64,7 @@ endif
libraw = dependency('libraw', version : '>= 0.13.2')
libexif = dependency('libexif', version : '>= 0.6.16')
unity = dependency('unity', required : false)
+gdk = [ dependency('gdk-x11-3.0'), dependency('gdk-wayland-3.0') ]
unity_available = false
if unity.found() and get_option('unity-support')