summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2018-09-30 14:09:20 +0200
committerJörg Frings-Fürst <debian@jff.email>2018-09-30 14:09:20 +0200
commit5e9f4eea451a77ba3b93db3747841ed2bd969e9f (patch)
tree75046a38ca68975261d853a2e56ff7bf6b3e1daa /meson.build
parent18b52c2983a1b3409011f72d27f15de576c5eb1c (diff)
New upstream version 0.30.1upstream/0.30.1
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build28
1 files changed, 20 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index c3d8468..f75ad49 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,6 @@
-project('Shotwell', ['vala', 'c'],
- version : '0.28.4',
+project('shotwell', ['vala', 'c'],
+ version : '0.30.1',
+ meson_version : '>= 0.43.0',
default_options : ['buildtype=debugoptimized'])
gnome = import('gnome')
@@ -35,7 +36,7 @@ if gitver.returncode() == 0
add_global_arguments(['--define=_GITVERSION'], language : 'vala')
endif
-gtk = dependency('gtk+-3.0', version : '>= 3.18')
+gtk = dependency('gtk+-3.0', version : '>= 3.22')
gio = dependency('gio-2.0', version: '>= 2.40')
gmodule = dependency('gmodule-2.0', version: '>= 2.40')
gio_unix = dependency('gio-unix-2.0', version: '>= 2.40')
@@ -44,20 +45,20 @@ webkit = dependency('webkit2gtk-4.0', version: '>= 2.4')
soup = dependency('libsoup-2.4')
json_glib = dependency('json-glib-1.0')
xml = dependency('libxml-2.0')
-gdk = dependency('gdk-3.0', version : '>= 3.18')
+gdk = dependency('gdk-3.0', version : '>= 3.22')
gdk_pixbuf = dependency('gdk-pixbuf-2.0')
sqlite = dependency('sqlite3', version : '>= 3.5.9')
gstreamer = dependency('gstreamer-1.0', version : '>= 1.0')
gstreamer_pbu = dependency('gstreamer-pbutils-1.0', version : '>= 1.0')
gphoto2 = dependency('libgphoto2', version : '>= 2.5.0')
-gudev = dependency('gudev-1.0', version : '>= 145')
+gudev = dependency('gudev-1.0', version : '>= 145', required: false)
gexiv2 = dependency('gexiv2', version: '>= 0.10.4')
libraw = dependency('libraw', version : '>= 0.13.2')
libexif = dependency('libexif', version : '>= 0.6.16')
unity = dependency('unity', required : false)
unity_available = false
-if unity.found() and get_option('enable-unity-support')
+if unity.found() and get_option('unity-support')
unity_available = true
add_global_arguments(['--define=UNITY_SUPPORT'], language : 'vala')
endif
@@ -77,8 +78,17 @@ foreach measure : get_option('measure').split(',')
language : 'vala')
endforeach
-if get_option('disable-dupe-detection')
- add_global_arguments(['--define=NO_DUPE_DETECTION'], language : vala)
+if not get_option('dupe-detection')
+ add_global_arguments(['--define=NO_DUPE_DETECTION'], language : 'vala')
+endif
+
+if get_option('udev') and gudev.found()
+ add_global_arguments(['--define=HAVE_UDEV'], language : 'vala')
+endif
+
+if get_option('face-detection')
+ add_global_arguments(['--define=ENABLE_FACES'], language : 'vala')
+ subdir('facedetect')
endif
json_glib = dependency('json-glib-1.0')
@@ -100,8 +110,10 @@ subdir('help')
subdir('misc')
subdir('thumbnailer')
subdir('settings-migrator')
+subdir('test')
subdir('app-icons')
+meson.add_install_script('build-aux/meson/postinstall.py')
if get_option('install-apport-hook')
subdir('apport')
endif