summaryrefslogtreecommitdiff
path: root/misc/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:43:08 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:43:08 +0200
commit2b3f22361da0c1d8e6ce70d71352821758186db7 (patch)
tree5d10633b47369b3aa52a05bf889ede0dbe5ee108 /misc/meson.build
parent211da5fc3048ca2b6ccee2166b0aaaade55cb84f (diff)
parentdc6c76eb04dfe3d4262a1806808f0bc0bf523238 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'misc/meson.build')
-rw-r--r--misc/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/meson.build b/misc/meson.build
new file mode 100644
index 0000000..664ddb0
--- /dev/null
+++ b/misc/meson.build
@@ -0,0 +1,28 @@
+podir = join_paths('..', 'po')
+
+i18n.merge_file(input : 'shotwell.appdata.xml.in',
+ output : 'shotwell.appdata.xml',
+ po_dir : join_paths('..', 'po'),
+ type : 'xml',
+ install: true,
+ install_dir : join_paths(get_option('datadir'), 'metainfo'))
+
+i18n.merge_file(input : 'shotwell.desktop.in',
+ output: 'shotwell.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+i18n.merge_file(input : 'shotwell-viewer.desktop.in',
+ output: 'shotwell-viewer.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+install_data(['org.yorba.shotwell-extras.gschema.xml',
+ 'org.yorba.shotwell.gschema.xml'],
+ install_dir : join_paths(get_option('datadir'), 'glib-2.0', 'schemas'))
+
+gnome.compile_schemas()