summaryrefslogtreecommitdiff
path: root/plugins/authenticator/shotwell/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:34:32 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:34:32 +0200
commit49120f48474fc8fdc2448c75d961bc238213cfac (patch)
tree05bcdb95d65a807cf0f1ffffd066c09074b5cf56 /plugins/authenticator/shotwell/meson.build
parent2492891f112caac6076ce49721d9d5d78a152c3a (diff)
New upstream version 0.28.2upstream/0.28.2
Diffstat (limited to 'plugins/authenticator/shotwell/meson.build')
-rw-r--r--plugins/authenticator/shotwell/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/plugins/authenticator/shotwell/meson.build b/plugins/authenticator/shotwell/meson.build
new file mode 100644
index 0000000..4404242
--- /dev/null
+++ b/plugins/authenticator/shotwell/meson.build
@@ -0,0 +1,28 @@
+authenticator_shotwell_sources = [
+ 'ShotwellAuthenticatorFactory.vala',
+ 'FacebookPublishingAuthenticator.vala',
+ 'FlickrPublishingAuthenticator.vala',
+ 'GoogleAuthenticator.vala',
+ 'OAuth1Authenticator.vala',
+ 'TumblrAuthenticator.vala'
+ ]
+
+authenticator_shotwell_resources = gnome.compile_resources('authenticator-resource',
+ 'org.gnome.Shotwell.Authenticator.gresource.xml',
+ source_dir : meson.source_root())
+
+authenticator_shotwell_deps = [gee, gtk, gio, soup, json_glib, sw_plugin,
+ sw_plugin_common_dep, json_glib, xml, webkit]
+
+authenticator = library('shotwell-authenticator',
+ authenticator_shotwell_sources + authenticator_shotwell_resources,
+ dependencies : authenticator_shotwell_deps,
+ include_directories : config_incdir,
+ version: meson.project_version(),
+ vala_args : ['--gresources',
+ 'org.gnome.Shotwell.Authenticator.gresource.xml'],
+ c_args :
+ '-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Authenticator"',
+ install: true)
+authenticator_dep = declare_dependency(include_directories : include_directories('.'),
+ link_with : authenticator)