summaryrefslogtreecommitdiff
path: root/plugins/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:34:32 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:34:32 +0200
commit49120f48474fc8fdc2448c75d961bc238213cfac (patch)
tree05bcdb95d65a807cf0f1ffffd066c09074b5cf56 /plugins/meson.build
parent2492891f112caac6076ce49721d9d5d78a152c3a (diff)
New upstream version 0.28.2upstream/0.28.2
Diffstat (limited to 'plugins/meson.build')
-rw-r--r--plugins/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/plugins/meson.build b/plugins/meson.build
new file mode 100644
index 0000000..66096c7
--- /dev/null
+++ b/plugins/meson.build
@@ -0,0 +1,24 @@
+# Plugin helper library
+
+sw_plugin_common = library('shotwell-plugin-common',
+ ['common/RESTSupport.vala',
+ 'common/Resources.vala',
+ 'common/WebAuthenticationPane.vala',
+ 'common/BuilderPane.vala',
+ 'common/OAuth1Support.vala'],
+ version: meson.project_version(),
+ dependencies : [gtk, gee, webkit, soup, xml, sw_plugin],
+ vala_header : 'shotwell-plugin-common.h',
+ vala_vapi : 'shotwell-plugin-common.vapi',
+ include_directories : config_incdir,
+ install : true)
+
+sw_plugin_common_dep = declare_dependency(include_directories : include_directories('.'),
+ link_with : sw_plugin_common)
+
+subdir('authenticator')
+subdir('shotwell-publishing')
+if get_option('enable-extra-plugins')
+ subdir('shotwell-publishing-extras')
+endif
+subdir('shotwell-transitions')