summaryrefslogtreecommitdiff
path: root/plugins/shotwell-publishing/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:34:32 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:34:32 +0200
commit49120f48474fc8fdc2448c75d961bc238213cfac (patch)
tree05bcdb95d65a807cf0f1ffffd066c09074b5cf56 /plugins/shotwell-publishing/meson.build
parent2492891f112caac6076ce49721d9d5d78a152c3a (diff)
New upstream version 0.28.2upstream/0.28.2
Diffstat (limited to 'plugins/shotwell-publishing/meson.build')
-rw-r--r--plugins/shotwell-publishing/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/plugins/shotwell-publishing/meson.build b/plugins/shotwell-publishing/meson.build
new file mode 100644
index 0000000..45058b8
--- /dev/null
+++ b/plugins/shotwell-publishing/meson.build
@@ -0,0 +1,25 @@
+shotwell_publishing_sources = [
+ 'shotwell-publishing.vala',
+ 'FacebookPublishing.vala',
+ 'PicasaPublishing.vala',
+ 'FlickrPublishing.vala',
+ 'TumblrPublishing.vala',
+ 'YouTubePublishing.vala',
+ 'PiwigoPublishing.vala']
+
+shotwell_publishing_resources = gnome.compile_resources('publishing-resource',
+ 'org.gnome.Shotwell.Publishing.gresource.xml',
+ source_dir : meson.source_root())
+
+shared_module('shotwell-publishing',
+ shotwell_publishing_sources + shotwell_publishing_resources,
+ dependencies : [gtk, soup, gexiv2, gee, sw_plugin, json_glib,
+ webkit, sw_plugin_common_dep, xml, gdata, gcr,
+ gcr_ui, authenticator_dep],
+ vala_args : [
+ '--gresources', 'org.gnome.Shotwell.Publishing.gresource.xml'
+ ],
+ c_args : ['-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Publishing"',
+ '-DGCR_API_SUBJECT_TO_CHANGE'],
+ install: true,
+ install_dir : shotwell_plugin_dir)