summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2018-09-30 14:09:20 +0200
committerJörg Frings-Fürst <debian@jff.email>2018-09-30 14:09:20 +0200
commit5e9f4eea451a77ba3b93db3747841ed2bd969e9f (patch)
tree75046a38ca68975261d853a2e56ff7bf6b3e1daa /src/meson.build
parent18b52c2983a1b3409011f72d27f15de576c5eb1c (diff)
New upstream version 0.30.1upstream/0.30.1
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build19
1 files changed, 17 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index ba260e7..c452a98 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -17,13 +17,25 @@ processor = executable('shotwell-graphics-processor',
dependencies: [gio, gdk, gee],
link_with: sw_graphics_processor)
+face_sources = []
+if get_option('face-detection')
+ face_sources = (['faces/FacesBranch.vala',
+ 'faces/FaceLocation.vala',
+ 'faces/FacePage.vala',
+ 'faces/FaceShape.vala',
+ 'faces/Faces.vala',
+ 'faces/Face.vala',
+ 'db/FaceLocationTable.vala',
+ 'db/FaceTable.vala',
+ 'faces/FacesTool.vala'])
+endif
+
shotwell_deps = [gio, gee, sqlite, gtk, sqlite, posix, gphoto2,
gstreamer_pbu, gio_unix, gudev, gexiv2, gmodule,
libraw, libexif, sw_plugin]
if unity_available
shotwell_deps += [unity]
endif
-
executable('shotwell',
['unit/Unit.vala',
'util/Util.vala',
@@ -58,6 +70,7 @@ executable('shotwell',
'photos/PhotoMetadata.vala',
'photos/GRaw.vala',
'photos/GdkSupport.vala',
+ 'photos/GifSupport.vala',
'photos/JfifSupport.vala',
'photos/BmpSupport.vala',
'photos/RawSupport.vala',
@@ -141,6 +154,8 @@ executable('shotwell',
'folders/Folders.vala',
'folders/FoldersBranch.vala',
'folders/FoldersPage.vala',
+ 'import-roll/ImportRollBranch.vala',
+ 'import-roll/ImportRollEntry.vala',
'main.vala',
'AppWindow.vala',
'CollectionPage.vala',
@@ -223,7 +238,7 @@ executable('shotwell',
'.unitize/_DataImportsInternals.vala',
'.unitize/_FoldersInternals.vala',
'.unitize/_Library_unitize_entry.vala',
- '.unitize/_Direct_unitize_entry.vala'] + shotwell_resources,
+ '.unitize/_Direct_unitize_entry.vala'] + shotwell_resources + face_sources,
include_directories : vapi_incdir,
dependencies : shotwell_deps,
vala_args : ['--pkg', 'libgphoto2',