summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 17 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7c86f18..bb37de5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,8 +5,8 @@ dnl ***********************************************************************
dnl Define Versioning Information
dnl ***********************************************************************
m4_define([major_version],[0])
-m4_define([minor_version],[26])
-m4_define([micro_version],[4])
+m4_define([minor_version],[28])
+m4_define([micro_version],[3])
m4_define([package_version],[major_version.minor_version.micro_version])
m4_define([bug_report_url],[https://bugzilla.gnome.org/enter_bug.cgi?product=shotwell])
m4_define([api_version],[major_version])
@@ -113,7 +113,7 @@ PKG_CHECK_MODULES(SHOTWELL, [
gstreamer-base-1.0 >= 1.0.0
gstreamer-plugins-base-1.0 >= 1.0.0
gstreamer-pbutils-1.0 >= 1.0.0
- gtk+-3.0 >= 3.14.0
+ gtk+-3.0 >= 3.18.0
gudev-1.0 >= 145
libexif >= 0.6.16
libgphoto2 >= 2.5.0
@@ -121,7 +121,7 @@ PKG_CHECK_MODULES(SHOTWELL, [
libxml-2.0 >= 2.6.32
sqlite3 >= 3.5.9
])
-PKG_CHECK_MODULES(THUMBNAILER, [gee-0.8 >= 0.8.5 gtk+-3.0 >= 3.14.0
+PKG_CHECK_MODULES(THUMBNAILER, [gee-0.8 >= 0.8.5 gtk+-3.0 >= 3.18.0
gstreamer-base-1.0 >= 1.0.0])
PKG_CHECK_MODULES(PLUGIN, [gobject-2.0 glib-2.0 json-glib-1.0 libxml-2.0
@@ -166,10 +166,21 @@ AC_SUBST([HAVE_UNITY])
AM_CONDITIONAL([HAVE_UNITY],[test "x$HAVE_UNITY" = "xyes"])
dnl ***********************************************************************
+dnl Ubuntu apport hook
+dnl ***********************************************************************
+AC_ARG_ENABLE([apport-hook],
+ AS_HELP_STRING([--enable-apport-hook],
+ [Install apport hook]),
+ [],
+ [enable_apport_hook=no])
+
+AM_CONDITIONAL([INSTALL_APPORT_HOOK], [test "x$enable_apport_hook" != "xno"])
+
+dnl ***********************************************************************
dnl Publishers
dnl ***********************************************************************
-m4_define(ALL_PUBLISHERS, [facebook, flickr, picasa, piwigo, youtube, gallery3, rajce, tumblr, yandex])
+m4_define(ALL_PUBLISHERS, [facebook, flickr, picasa, piwigo, youtube, gallery3, tumblr])
AC_ARG_ENABLE([publishers],
AS_HELP_STRING([--enable-publishers=@<:@list-of-publishers or all@:>@],
[A comma-separated list of publishers from ALL_PUBLISHERS]),
@@ -275,6 +286,7 @@ AC_CONFIG_FILES([
app-icons/Makefile
icons/Makefile
ui/Makefile
+ apport/Makefile
],[],
[API_VERSION='$API_VERSION'])
AC_OUTPUT