summaryrefslogtreecommitdiff
path: root/debian/patches/0110-use_relative_lib_path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0110-use_relative_lib_path.patch')
-rw-r--r--debian/patches/0110-use_relative_lib_path.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/patches/0110-use_relative_lib_path.patch b/debian/patches/0110-use_relative_lib_path.patch
new file mode 100644
index 0000000..3e64e9f
--- /dev/null
+++ b/debian/patches/0110-use_relative_lib_path.patch
@@ -0,0 +1,22 @@
+Description: Use relative path for lib
+Author: Jens Georg <mail@jensge.org>
+Origin: upstream, https://gitlab.gnome.org/GNOME/shotwell/-/commit/b3216719e9504518d6866adaaec532e5a7c09481
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1010571
+Forwarded: not-needed
+Applied-Upstream: commit
+Last-Update: 2022-05-04
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/meson.build
+===================================================================
+--- trunk.orig/meson.build
++++ trunk/meson.build
+@@ -12,7 +12,7 @@ conf.set('_VERSION', '"@0@"'.format(meso
+ conf.set('_PREFIX', '"@0@"'.format(get_option('prefix')))
+ conf.set('_LANG_SUPPORT_DIR', '"@0@"'.format(join_paths(get_option('prefix'), get_option('localedir'))))
+ conf.set('_LIBEXECDIR', '"@0@"'.format(join_paths(get_option('prefix'), get_option('libexecdir'))))
+-conf.set('_LIB', '"@0@"'.format(join_paths(get_option('prefix'), get_option('libdir'))))
++conf.set('_LIB', '"@0@"'.format(get_option('libdir')))
+ configure_file(output : 'config.h', configuration: conf)
+
+ config_incdir = include_directories('.')