summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 10 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 04cf0a5..073afce 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project('shotwell', ['vala', 'c'],
- version : '0.30.8',
+ version : '0.30.10',
meson_version : '>= 0.43.0',
default_options : ['buildtype=debugoptimized'])
@@ -25,10 +25,18 @@ add_global_arguments(['--target-glib=2.40',
'--vapidir=@0@'.format(join_paths(meson.current_source_dir(),
'vapi')),
'--enable-checking',
- '--fatal-warnings',
'--enable-experimental',
'--enable-deprecated'], language : 'vala')
+if get_option('fatal_warnings')
+ add_global_arguments(
+ [
+ '--fatal-warnings'
+ ],
+ language : 'vala'
+ )
+endif
+
gitver = run_command(find_program('git-hash'))
if gitver.returncode() == 0
add_global_arguments(['-D_GIT_VERSION="@0@"'.format(gitver.stdout().strip())],