summaryrefslogtreecommitdiff
path: root/plugins/shotwell-publishing/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/shotwell-publishing/meson.build')
-rw-r--r--plugins/shotwell-publishing/meson.build11
1 files changed, 6 insertions, 5 deletions
diff --git a/plugins/shotwell-publishing/meson.build b/plugins/shotwell-publishing/meson.build
index 45058b8..eeac177 100644
--- a/plugins/shotwell-publishing/meson.build
+++ b/plugins/shotwell-publishing/meson.build
@@ -1,11 +1,15 @@
shotwell_publishing_sources = [
'shotwell-publishing.vala',
'FacebookPublishing.vala',
- 'PicasaPublishing.vala',
'FlickrPublishing.vala',
'TumblrPublishing.vala',
'YouTubePublishing.vala',
- 'PiwigoPublishing.vala']
+ 'PiwigoPublishing.vala',
+ 'PhotosPublisher.vala',
+ 'PhotosService.vala',
+ 'PhotosPublishingPane.vala',
+ 'PhotosUploader.vala'
+]
shotwell_publishing_resources = gnome.compile_resources('publishing-resource',
'org.gnome.Shotwell.Publishing.gresource.xml',
@@ -16,9 +20,6 @@ shared_module('shotwell-publishing',
dependencies : [gtk, soup, gexiv2, gee, sw_plugin, json_glib,
webkit, sw_plugin_common_dep, xml, gdata, gcr,
gcr_ui, authenticator_dep],
- vala_args : [
- '--gresources', 'org.gnome.Shotwell.Publishing.gresource.xml'
- ],
c_args : ['-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Publishing"',
'-DGCR_API_SUBJECT_TO_CHANGE'],
install: true,