summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAlessio Treglia <alessio@debian.org>2013-01-16 00:36:57 +0000
committerAlessio Treglia <alessio@debian.org>2013-01-16 00:36:57 +0000
commit3a30e3c8eb7bbd9eb3807536edeaff34be92f814 (patch)
tree2bcf26bac29eafa34c8111289fa6e09f9c22b070 /debian/rules
parentfebbb65e73b32cc7b66acff138c32c3b97a5b008 (diff)
debian/rules:
- Use dh_autoreconf instead of calling autoreconf before the configure. - Properly purge the symlink to gnome-doc-utils.make once the build's completed.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 8 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 67fa7e8..7abb6da 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,17 +8,21 @@ export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
LDFLAGS+=-Wl,--as-needed
%:
- dh $@ --with scour
+ dh $@ --with=autoreconf,scour
# Fixes FTBFS
override_dh_auto_test:
# Autoreconf due to 01_lpi.patch
-override_dh_auto_configure:
+override_dh_autoreconf:
[ -e gnome-doc-utils.make ] || \
ln -s /usr/share/gnome-doc-utils/gnome-doc-utils.make
- autoreconf -f -i -s
- dh_auto_configure
+ dh_autoreconf
+
+override_dh_auto_clean:
+ dh_auto_clean
+ [ ! -h gnome-doc-utils.make ] || \
+ rm gnome-doc-utils.make
override_dh_auto_build:
cd po; intltool-update -p