summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAlessio Treglia <alessio@debian.org>2010-09-17 19:45:40 +0200
committerAlessio Treglia <alessio@debian.org>2010-09-17 19:45:40 +0200
commit538a1b360ca3153d4b7a57f6e71bb7dd06caa638 (patch)
tree79219dddb8e736f62875deeb59cc8fde050c7d0b /debian/rules
parent888bee35ecceab1ecc104e483fd42dad6bf060d1 (diff)
Switch back to format 1.0
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 17 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 76a786f..a781c17 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,25 @@
#!/usr/bin/make -f
+DISTRIBUTION = $(shell lsb_release -i | cut -f2 -d':' | tr -d '\t')
LDFLAGS+=-Wl,--as-needed
%:
- dh $@
+ dh $@ --with=quilt
+
+override_dh_quilt_unpatch:
+ dh_quilt_unpatch
+ifeq ("$(DISTRIBUTION)", "Ubuntu")
+ if test -e debian/patches/series.old; then \
+ mv debian/patches/series.old debian/patches/series ;\
+ fi
+endif
+
+override_dh_quilt_patch:
+ifeq ("$(DISTRIBUTION)", "Ubuntu")
+ cp debian/patches/series debian/patches/series.old
+ echo 20-lpi.patch >> debian/patches/series
+endif
+ dh_quilt_patch
# Fixes FTBFS
override_dh_auto_test: