summaryrefslogtreecommitdiff
path: root/help/Makefile.am
diff options
context:
space:
mode:
authorAlessio Treglia <alessio@debian.org>2010-10-26 17:12:56 +0200
committerAlessio Treglia <alessio@debian.org>2010-10-26 17:12:56 +0200
commitfafc0daa6bd26ad254943315f253b1b218e71080 (patch)
tree2d09b07a68c0236fe5b0b7a4ebdb630c96610b4d /help/Makefile.am
parent516b7d5c6b94b4496609a4a758c21d0cdc2bbfa2 (diff)
Imported Upstream version 2.32.0.1upstream/2.32.0.1
Diffstat (limited to 'help/Makefile.am')
-rw-r--r--help/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/help/Makefile.am b/help/Makefile.am
index a901f88..135913d 100644
--- a/help/Makefile.am
+++ b/help/Makefile.am
@@ -21,3 +21,27 @@ DOC_LINGUAS =
DISTCLEANFILES = \
Makefile.in
+
+REAL_LINGUAS = de
+
+DOC_LINGUAS = POT $(REAL_LINGUAS)
+
+$(_DOC_LC_DOCS) : po.stamp
+
+po.stamp: $(wildcard translations/*.po)
+ for p in $?; do $(mkdir_p) $$(basename $$p .po)/; \
+ cp -a $$p $$(basename $$p .po)/; done
+ touch $@
+
+update-pot: translations/simple-scan-help.pot
+POT/POT.po: $(foreach page,$(DOC_PAGES),C/$(page))
+translations/simple-scan-help.pot: POT/POT.po
+ $(mkdir_p) $(dir $@)
+ sed 's|^#: /.*/\(.*\)|#: \1|g' $^ > $@
+
+dist-hook: doc-dist-hook
+
+EXTRA_DIST = translations po.stamp
+DISTCLEANFILES = translations/simple-scan-help.pot
+
+.PHONY: update-pot