summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2021-08-21 10:58:17 +0200
committerJörg Frings-Fürst <debian@jff.email>2021-08-21 10:58:17 +0200
commit383626437ca8f9d26518408719b5d778e696eecd (patch)
tree31c1e0bc563aa3705771e54e8514c03af5fe330d /meson.build
parentefe8a90877a031270375c1f2c0f1823560d85100 (diff)
New upstream version 40.1upstream/40.1
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build29
1 files changed, 28 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 00b34b9..5c468b5 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project ('simple-scan', ['vala', 'c'],
- version: '3.38.2',
+ version: '40.1',
license: 'GPLv3+',
default_options: [
'warning_level=1',
@@ -7,6 +7,12 @@ project ('simple-scan', ['vala', 'c'],
],
meson_version: '>= 0.37.1')
+# FIXME Disable --disable-since-check after libhandy 1.2 is released
+add_project_arguments (
+ '--disable-since-check',
+ language: 'vala'
+)
+
gnome = import ('gnome')
i18n = import ('i18n')
@@ -23,6 +29,7 @@ glib_dep = dependency ('glib-2.0', version: '>= 2.38')
gtk_dep = dependency ('gtk+-3.0', version: '>=3.22')
gmodule_dep = dependency ('gmodule-export-2.0')
gthread_dep = dependency ('gthread-2.0')
+libhandy_dep = dependency ('libhandy-1', version: '>= 1.1.90', required: false)
zlib_dep = dependency ('zlib')
cairo_dep = dependency ('cairo')
gdk_pixbuf_dep = dependency ('gdk-pixbuf-2.0')
@@ -35,6 +42,26 @@ sane_dep = dependency ('sane-backends')
msgfmt = find_program ('msgfmt')
itstool = find_program ('itstool')
+libhandy_subproj = libhandy_dep
+if not libhandy_dep.found()
+ libhandy_subproj = subproject(
+ 'libhandy',
+ default_options: [
+ 'examples=false',
+ 'glade_catalog=disabled',
+ 'tests=false',
+ ]
+ )
+
+ # When using libhandy as subproject, make sure we get the VAPI file
+ libhandy_dep = declare_dependency(
+ dependencies: [
+ libhandy_subproj.get_variable('libhandy_dep'),
+ libhandy_subproj.get_variable('libhandy_vapi'),
+ ]
+ )
+endif
+
subdir ('po')
subdir ('data')
subdir ('help')