summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 19 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d53c561..80dd44a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(simple-scan, 3.18.0)
+AC_INIT(simple-scan, 3.19.1)
AM_INIT_AUTOMAKE([1.11 no-dist-gzip dist-xz foreign])
AM_SILENT_RULES([yes])
AM_MAINTAINER_MODE
@@ -29,7 +29,6 @@ PKG_CHECK_MODULES(SIMPLE_SCAN, [
cairo
gdk-pixbuf-2.0
gusb
- packagekit-glib2
])
PKG_CHECK_MODULES(COLORD, [
@@ -37,6 +36,11 @@ PKG_CHECK_MODULES(COLORD, [
], have_colord=yes, have_colord=no)
AM_CONDITIONAL(HAVE_COLORD, test $have_colord = yes)
+PKG_CHECK_MODULES(PACKAGEKIT, [
+ packagekit-glib2
+], have_packagekit=yes, have_packagekit=no)
+AM_CONDITIONAL(HAVE_PACKAGEKIT, test $have_packagekit = yes)
+
AC_CHECK_HEADERS([sane/sane.h],[],[AC_MSG_ERROR([SANE not found])])
AC_CHECK_HEADERS([sane/saneopts.h],[],[AC_MSG_ERROR([SANE not found])])
@@ -66,3 +70,16 @@ help/Makefile
po/Makefile.in
src/Makefile
])
+
+dnl ###########################################################################
+dnl Summary
+dnl ###########################################################################
+
+echo "
+ Simple Scan $VERSION
+ ====================
+
+ prefix: $prefix
+ PackageKit support: $have_packagekit
+ Color management: $have_colord
+"