summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 26a07d8..aa152be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,18 +1,16 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(configure.ac)
-AM_INIT_AUTOMAKE(simple-scan, 3.6.1)
-AM_CONFIG_HEADER(config.h)
+AC_INIT(simple-scan, 3.10.0)
+AM_INIT_AUTOMAKE([1.11 no-dist-gzip dist-xz foreign])
+AM_SILENT_RULES([yes])
AM_MAINTAINER_MODE
GNOME_MAINTAINER_MODE_DEFINES
-m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
-AC_ISC_POSIX
AM_PROG_VALAC([0.16.0])
AM_PROG_CC_C_O
-AC_HEADER_STDC
GLIB_GSETTINGS
+AC_PATH_PROG(GLIB_COMPILE_RESOURCES, glib-compile-resources)
dnl ###########################################################################
dnl Dependencies
@@ -23,6 +21,7 @@ dnl * gnome-icon-theme
dnl * xdg-utils (for xdg-email)
PKG_CHECK_MODULES(SIMPLE_SCAN, [
+ glib-2.0 >= 2.32
gtk+-3.0
gmodule-export-2.0
gthread-2.0
@@ -30,6 +29,7 @@ PKG_CHECK_MODULES(SIMPLE_SCAN, [
cairo
gdk-pixbuf-2.0
gudev-1.0
+ sqlite3
])
PKG_CHECK_MODULES(COLORD, [
@@ -39,7 +39,6 @@ AM_CONDITIONAL(HAVE_COLORD, test $have_colord = yes)
AC_CHECK_HEADERS([sane/sane.h],[],[AC_MSG_ERROR([SANE not found])])
AC_CHECK_HEADERS([sane/saneopts.h],[],[AC_MSG_ERROR([SANE not found])])
-AC_CHECK_HEADERS([jpeglib.h],[],[AC_MSG_ERROR([libjpeg not found])])
dnl ###########################################################################
dnl Documentation