summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..178001b
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,39 @@
+project ('simple-scan', ['vala', 'c'],
+ version: '3.26.2',
+ license: 'GPLv3+',
+ default_options: [
+ 'warning_level=1',
+ 'buildtype=debugoptimized',
+ ],
+ meson_version: '>= 0.37.1')
+
+gnome = import ('gnome')
+i18n = import ('i18n')
+
+# Paths
+mandir = join_paths (get_option ('prefix'), get_option ('mandir'))
+localedir = join_paths (get_option ('prefix'), get_option ('localedir'))
+datadir = join_paths (get_option ('prefix'), get_option ('datadir'))
+icondir = join_paths (datadir, 'simple-scan', 'icons')
+
+# Dependencies
+glib_dep = dependency ('glib-2.0', version: '>= 2.38')
+gtk_dep = dependency ('gtk+-3.0', version: '>=3.12')
+gmodule_dep = dependency ('gmodule-export-2.0')
+gthread_dep = dependency ('gthread-2.0')
+zlib_dep = dependency ('zlib')
+cairo_dep = dependency ('cairo')
+gdk_pixbuf_dep = dependency ('gdk-pixbuf-2.0')
+gusb_dep = dependency ('gusb', version: '>= 0.2.7')
+colord_dep = dependency ('colord', required: false)
+packagekit_dep = dependency ('packagekit-glib2', version: '>= 1.1.5', required: false)
+webp_dep = dependency ('libwebp', required: false)
+webpmux_dep = dependency ('libwebpmux', required: false)
+sane_dep = dependency ('sane-backends')
+msgfmt = find_program ('msgfmt')
+itstool = find_program ('itstool')
+
+subdir ('po')
+subdir ('data')
+subdir ('help')
+subdir ('src')