summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhsoting.net>2019-04-28 20:11:31 +0200
committerJörg Frings-Fürst <debian@jff-webhsoting.net>2019-04-28 20:11:31 +0200
commitb08941cd7113d882790c7d62edb59f31649daadd (patch)
tree71c7ebd5d80cdfd4507b013968f96b78a0cc316a /CMakeLists.txt
parent1920f1b489a54e8ab97a3e24b1bab64831e32b53 (diff)
New upstream version 0.9.3upstream/0.9.3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 749fea1..ceb79e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,12 +38,12 @@ cmake_minimum_required(VERSION 3.3)
project(uriparser
VERSION
- 0.9.2
+ 0.9.3
)
# See https://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
set(URIPARSER_SO_CURRENT 1)
-set(URIPARSER_SO_REVISION 25)
+set(URIPARSER_SO_REVISION 26)
set(URIPARSER_SO_AGE 0)
include(CheckCCompilerFlag)
@@ -151,6 +151,9 @@ if(NOT MSVC)
math(EXPR URIPARSER_SO_CURRENT_MINUS_AGE "${URIPARSER_SO_CURRENT} - ${URIPARSER_SO_AGE}")
set_property(TARGET uriparser PROPERTY VERSION ${URIPARSER_SO_CURRENT_MINUS_AGE}.${URIPARSER_SO_AGE}.${URIPARSER_SO_REVISION})
set_property(TARGET uriparser PROPERTY SOVERSION ${URIPARSER_SO_CURRENT_MINUS_AGE})
+ if(WIN32)
+ set_property(TARGET uriparser PROPERTY SUFFIX "-${URIPARSER_SO_CURRENT_MINUS_AGE}${CMAKE_SHARED_LIBRARY_SUFFIX}")
+ endif()
endif()
set_property(