summaryrefslogtreecommitdiff
path: root/debian/patches/0001-missing_pthread.patch
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhsoting.net>2019-07-13 18:02:05 +0200
committerJörg Frings-Fürst <debian@jff-webhsoting.net>2019-07-13 18:02:05 +0200
commitd3f17d40ea57a789b3466db81a3b70fb1294242c (patch)
treea4015847bd6abc9ec1f477bccbd604dedc75a430 /debian/patches/0001-missing_pthread.patch
parent0f5013c408b76b33f86478daa874ddc44df9b869 (diff)
Rewrite build process; Refresh symbols file
Diffstat (limited to 'debian/patches/0001-missing_pthread.patch')
-rw-r--r--debian/patches/0001-missing_pthread.patch20
1 files changed, 19 insertions, 1 deletions
diff --git a/debian/patches/0001-missing_pthread.patch b/debian/patches/0001-missing_pthread.patch
index 3054ce9..8afe6ae 100644
--- a/debian/patches/0001-missing_pthread.patch
+++ b/debian/patches/0001-missing_pthread.patch
@@ -2,12 +2,30 @@ Index: trunk/CMakeLists.txt
===================================================================
--- trunk.orig/CMakeLists.txt
+++ trunk/CMakeLists.txt
-@@ -209,7 +209,7 @@ if(URIPARSER_BUILD_TOOLS)
+@@ -212,7 +212,8 @@ if(URIPARSER_BUILD_TOOLS)
tool/uriparse.c
)
- target_link_libraries(uriparse PUBLIC uriparser)
++ find_package(Threads REQUIRED)
+ target_link_libraries(uriparse PUBLIC uriparser pthread)
if(HAIKU)
# Function inet_ntop needs -lsocket or -lnetwork (see pull request #45)
+@@ -245,6 +246,7 @@ if(URIPARSER_BUILD_TESTS)
+ enable_testing()
+
+ find_package(GTest 1.8.1 REQUIRED)
++ find_package(Threads REQUIRED)
+
+ add_executable(testrunner
+ test/FourSuite.cpp
+@@ -274,7 +276,7 @@ if(URIPARSER_BUILD_TESTS)
+ )
+
+ target_link_libraries(testrunner PUBLIC
+- ${GTEST_BOTH_LIBRARIES}
++ ${GTEST_BOTH_LIBRARIES} pthread
+ )
+
+ add_test(