summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9b80f71..313092a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,14 +38,14 @@ cmake_minimum_required(VERSION 3.3)
project(uriparser
VERSION
- 0.9.6
+ 0.9.7
LANGUAGES
C
)
# See https://verbump.de/ for what these numbers do
set(URIPARSER_SO_CURRENT 1)
-set(URIPARSER_SO_REVISION 29)
+set(URIPARSER_SO_REVISION 30)
set(URIPARSER_SO_AGE 0)
include(CheckCCompilerFlag)
@@ -110,11 +110,11 @@ if(URIPARSER_COMPILER_SUPPORTS_VISIBILITY)
endif()
#
-# config.h
+# UriConfig.h
#
check_symbol_exists(wprintf wchar.h HAVE_WPRINTF)
check_function_exists(reallocarray HAVE_REALLOCARRAY) # no luck with CheckSymbolExists
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/UriConfig.h.in config.h)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/UriConfig.h.in UriConfig.h)
#
# C library
@@ -193,7 +193,7 @@ target_include_directories(uriparser
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
$<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>
PRIVATE
- ${CMAKE_CURRENT_BINARY_DIR} # for config.h
+ ${CMAKE_CURRENT_BINARY_DIR} # for UriConfig.h
)
uriparser_install(
@@ -288,7 +288,7 @@ if(URIPARSER_BUILD_TESTS)
target_include_directories(testrunner PRIVATE
${CMAKE_CURRENT_SOURCE_DIR}/include
- ${CMAKE_CURRENT_BINARY_DIR} # for config.h
+ ${CMAKE_CURRENT_BINARY_DIR} # for UriConfig.h
)
target_link_libraries(testrunner PUBLIC