summaryrefslogtreecommitdiff
path: root/debian/patches/0005-autoconf-updates.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0005-autoconf-updates.diff')
-rw-r--r--debian/patches/0005-autoconf-updates.diff453
1 files changed, 453 insertions, 0 deletions
diff --git a/debian/patches/0005-autoconf-updates.diff b/debian/patches/0005-autoconf-updates.diff
new file mode 100644
index 0000000..02dcfe7
--- /dev/null
+++ b/debian/patches/0005-autoconf-updates.diff
@@ -0,0 +1,453 @@
+Description: patch to run autoconf
+
+Index: b/AUTHORS
+===================================================================
+--- /dev/null
++++ b/AUTHORS
+@@ -0,0 +1,47 @@
++
++This is a list of the people who are or have worked on the xbase64 Library.
++
++Gary Kunkel <gkunkel@zhsac.com> - original author,
++ current maintainer of xbase64
++Larry McCourry <lmccourry@charter.net - memory leak testing
++Sergiy Yakovin <s.yakovin@if.ukrsotsbank.com> - cdx index support
++
++Previous to this library being branced to xbase64, the following AUTHORS have
++supported xbase to the 2.x release level.
++
++
++
++------------------------------------------------------------------------------
++The following list is the AUTHORS file for the xbase library release 2.
++------------------------------------------------------------------------------
++This is a partial list of the people that have helped with the xbase
++project and something specific they worked on. Most have worked on more
++than what is listed.
++
++Derry Bryson <derry@techass.com> - release 2.x maintainer
++Mario Motta - testing and bugfixes
++Serge Smirnov <sw1181@mail.ru> - MSVC stuff and OCAML support
++Frolov Sergey - bugfixes (memory leaks)
++
++------------------------------------------------------------------------------
++The following is the original AUTHORS file for the xbase library
++------------------------------------------------------------------------------
++This is a partial list of the people that have helped with the xbase
++project and something specific they worked on. Most have worked on more
++than what is listed.
++
++
++Bob Cotton <bcotton@synix.com> - Clipper NTX index support
++Denis Braussen <postoffice@mail.dotcom.fr> - general support
++Denis Pershin <dyp@inetlab.com> - provided library enhancements
++Eirk Bachman <ebp@geocities.com> - keeper of definitive Xbase spec
++Gabriel Emerson <egabriel@io.com> - provided logo
++Kehl Hubertus <kehlh@hotmail.com> - Xbase to Xbase C++ Perl Converter
++Michael Bedward <mbedward@ozemail.com.au> - Expression logic support
++Paul Foster <paulf@quillandmouse.com> - general support
++Vitaly Fedrushkov <willy@snowyowl.csu.ac.ru> - TV support and more
++
++------------------------------------------------------------------------------
++
++If you are missing and you should be included in this file, please let me
++know at xbase64-dev@lists.sourceforge.net. Thanks, Gary Kunkel.
+Index: b/NEWS
+===================================================================
+--- /dev/null
++++ b/NEWS
+@@ -0,0 +1,49 @@
++
++Xbase64 (Sept 15, 2003)
++------------------------
++
++Xbase64 was branched off the xbase C++ class lib project and given a new name.
++
++There are significant changes in this release.
++
++1) The original author (Gary Kunkel) has resumed working on the project.
++
++2) The project was branched and renamed to xbase64 with 64 bit file
++ processing capabilities. The xbase name is being used by other projects,
++ so I thought it was time for a new name.
++
++3) Modified the license from LGPL to GPL as recommended by the GNU web site.
++ Files that I have not been able to get permission from the original
++ author for GPL terms have beed deleted from the library.
++
++4) Trimmed the tree: Dropped support for the xbHtml class, the turbo vision
++ interface, and the ybase directory. These are either unused, not working,
++ undocumented, not maintained, or I didn't have authority to change the
++ license from LGPL to GPL.
++
++5) Didn't move make files forward that were not documented or working.
++ These need to be reviewed and brought forward.
++
++6) Worked on the locking logic.
++
++7) Added support for Borland C++ 5.x compiler.
++
++8) Created a new data type of XB_BOOL. Current bool data type was causing
++ issues in certain environments.
++
++9) Dropped support for XB_CASTELLANO dates. Changed the logic to use
++ system locale settings, this supports descriptive dates in different
++ languages.
++
++10) Cleaned up memory leaks.
++
++11) Updates to the documentation.
++
++12) Enhancements to the expression logic
++
++13) Fixed the broken index logic - the ndx and ntx indices are working
++ again.
++
++-----------------------------------------------------------------------
++For a the historical NEWS file history (pre 9/15/03), review the older
++xbase library.
+Index: b/README
+===================================================================
+--- /dev/null
++++ b/README
+@@ -0,0 +1,108 @@
++ Xbase64 Version 3.1.0
++
++
++
++WHAT IS IT?
++-----------
++
++Xbase64 is an xbase (i.e. dBase, FoxPro, etc.) compatible C++ class library
++originally by Gary Kunkel and others (see the AUTHORS file).
++
++Xbase64 is useful for accessing data in legacy dBase 3 and 4 database files as
++well as a general light-weight database engine. It includes support for
++DBF (dBase version 3 and 4) data files, NDX and NTX indexes, and DBT
++(dBase version 3 and 4). It supports file and record locking under *nix
++and Windows.
++
++
++DIRECTORY LAYOUT
++----------------
++
++ /bin contains various utility programs
++ /examples contains various test programs
++ /html contains the original xBase documentation in html format
++ /xbase64 Xbase64 source and header files
++
++
++BUILDING THE LIBRARY ON UNIX/LINUX
++----------------------------------
++
++XBase64 uses autoconf and libtool to manage the build process.
++
++To configure the library for your specific system, run the "configure"
++shell script as follows:
++
++ ./configure
++
++The configure script accepts the following options in addition to the
++normal default options:
++
++ --enable-debug creates debugging code [default=no]
++ --enable-shared build shared libraries [default=yes]
++ --enable-static build static libraries [default=no]
++ --with-gnu-ld assume the C compiler uses GNU ld [default=no]
++ --without-index-ndx turn off .ndx index support
++ --without-index-ntx turn off .ntx index support
++ --without-memo-fields turn off memo fields support
++ --without-expressions turn off expressions support
++ --without-xbase-locking turn off XBase file locking
++ --without-realdelete turn off XBase record deletion
++ --without-xbase-debug turn off XBase specific debug
++ --without-largefile-support turn off XBase largefile support
++
++Once configured, execute make as follows to build the library:
++
++ make
++
++Once compiled (and assuming no errors occurred), use make to install the
++library, header files, and utilities as follows:
++
++ make install
++
++The default install directory is /usr/local.
++
++
++BUILDING THE LIBRARY ON WINDOWS
++-------------------------------
++
++The MINGW32 and CYGWIN compiler support didn't make the first cut to
++Xbase64. They will be migrated forward in a future release of xbase64.
++Any volunteers?
++
++If using the MINGW32 GCC compiler package, use the makefile.g95 make files.
++Edit bin/makefile.g95 xbase/makefile.g95 to change installation directories.
++
++If using the CYGWIN environment, use the makefile.cyg make files (or fix
++the autoconf/automake stuff to work correclty). However, for some reason
++(as yet undetermined) it seems to run very slowly when compiled with the
++cygwin compiler (perhaps the file handing in the cygwin dll is just dog slow?).
++
++
++BUILDING THE LIRARY WITH BORLAND 5.5
++------------------------------------
++
++There are batch files MAKEBCC.BAT which build the xbase libs for
++Borland C++ 5.5.
++
++
++
++DOCUMENTATION
++-------------
++
++The documentation at this point consists of the original xBase documentation
++(in the html directory). It is still very useful as little has changed
++from the original library except bugfixes and a few enhancements.
++
++We are working on incorporating comments into the source to allow
++generation of reference documentation using the Doxygen document generator.
++A small amount has been done already, but we hope to complete this effort
++before the next release.
++
++
++CONTACT
++-------
++
++Please email comments, bug reports, and patches to Gary Kunkel
++xdb-dev@lists.sourceforge.net
++
++
+Index: b/authors
+===================================================================
+--- a/authors
++++ /dev/null
+@@ -1,47 +0,0 @@
+-
+-This is a list of the people who are or have worked on the xbase64 Library.
+-
+-Gary Kunkel <gkunkel@zhsac.com> - original author,
+- current maintainer of xbase64
+-Larry McCourry <lmccourry@charter.net - memory leak testing
+-Sergiy Yakovin <s.yakovin@if.ukrsotsbank.com> - cdx index support
+-
+-Previous to this library being branced to xbase64, the following AUTHORS have
+-supported xbase to the 2.x release level.
+-
+-
+-
+-------------------------------------------------------------------------------
+-The following list is the AUTHORS file for the xbase library release 2.
+-------------------------------------------------------------------------------
+-This is a partial list of the people that have helped with the xbase
+-project and something specific they worked on. Most have worked on more
+-than what is listed.
+-
+-Derry Bryson <derry@techass.com> - release 2.x maintainer
+-Mario Motta - testing and bugfixes
+-Serge Smirnov <sw1181@mail.ru> - MSVC stuff and OCAML support
+-Frolov Sergey - bugfixes (memory leaks)
+-
+-------------------------------------------------------------------------------
+-The following is the original AUTHORS file for the xbase library
+-------------------------------------------------------------------------------
+-This is a partial list of the people that have helped with the xbase
+-project and something specific they worked on. Most have worked on more
+-than what is listed.
+-
+-
+-Bob Cotton <bcotton@synix.com> - Clipper NTX index support
+-Denis Braussen <postoffice@mail.dotcom.fr> - general support
+-Denis Pershin <dyp@inetlab.com> - provided library enhancements
+-Eirk Bachman <ebp@geocities.com> - keeper of definitive Xbase spec
+-Gabriel Emerson <egabriel@io.com> - provided logo
+-Kehl Hubertus <kehlh@hotmail.com> - Xbase to Xbase C++ Perl Converter
+-Michael Bedward <mbedward@ozemail.com.au> - Expression logic support
+-Paul Foster <paulf@quillandmouse.com> - general support
+-Vitaly Fedrushkov <willy@snowyowl.csu.ac.ru> - TV support and more
+-
+-------------------------------------------------------------------------------
+-
+-If you are missing and you should be included in this file, please let me
+-know at xbase64-dev@lists.sourceforge.net. Thanks, Gary Kunkel.
+Index: b/news
+===================================================================
+--- a/news
++++ /dev/null
+@@ -1,49 +0,0 @@
+-
+-Xbase64 (Sept 15, 2003)
+-------------------------
+-
+-Xbase64 was branched off the xbase C++ class lib project and given a new name.
+-
+-There are significant changes in this release.
+-
+-1) The original author (Gary Kunkel) has resumed working on the project.
+-
+-2) The project was branched and renamed to xbase64 with 64 bit file
+- processing capabilities. The xbase name is being used by other projects,
+- so I thought it was time for a new name.
+-
+-3) Modified the license from LGPL to GPL as recommended by the GNU web site.
+- Files that I have not been able to get permission from the original
+- author for GPL terms have beed deleted from the library.
+-
+-4) Trimmed the tree: Dropped support for the xbHtml class, the turbo vision
+- interface, and the ybase directory. These are either unused, not working,
+- undocumented, not maintained, or I didn't have authority to change the
+- license from LGPL to GPL.
+-
+-5) Didn't move make files forward that were not documented or working.
+- These need to be reviewed and brought forward.
+-
+-6) Worked on the locking logic.
+-
+-7) Added support for Borland C++ 5.x compiler.
+-
+-8) Created a new data type of XB_BOOL. Current bool data type was causing
+- issues in certain environments.
+-
+-9) Dropped support for XB_CASTELLANO dates. Changed the logic to use
+- system locale settings, this supports descriptive dates in different
+- languages.
+-
+-10) Cleaned up memory leaks.
+-
+-11) Updates to the documentation.
+-
+-12) Enhancements to the expression logic
+-
+-13) Fixed the broken index logic - the ndx and ntx indices are working
+- again.
+-
+------------------------------------------------------------------------
+-For a the historical NEWS file history (pre 9/15/03), review the older
+-xbase library.
+Index: b/readme
+===================================================================
+--- a/readme
++++ /dev/null
+@@ -1,108 +0,0 @@
+- Xbase64 Version 3.1.0
+-
+-
+-
+-WHAT IS IT?
+------------
+-
+-Xbase64 is an xbase (i.e. dBase, FoxPro, etc.) compatible C++ class library
+-originally by Gary Kunkel and others (see the AUTHORS file).
+-
+-Xbase64 is useful for accessing data in legacy dBase 3 and 4 database files as
+-well as a general light-weight database engine. It includes support for
+-DBF (dBase version 3 and 4) data files, NDX and NTX indexes, and DBT
+-(dBase version 3 and 4). It supports file and record locking under *nix
+-and Windows.
+-
+-
+-DIRECTORY LAYOUT
+-----------------
+-
+- /bin contains various utility programs
+- /examples contains various test programs
+- /html contains the original xBase documentation in html format
+- /xbase64 Xbase64 source and header files
+-
+-
+-BUILDING THE LIBRARY ON UNIX/LINUX
+-----------------------------------
+-
+-XBase64 uses autoconf and libtool to manage the build process.
+-
+-To configure the library for your specific system, run the "configure"
+-shell script as follows:
+-
+- ./configure
+-
+-The configure script accepts the following options in addition to the
+-normal default options:
+-
+- --enable-debug creates debugging code [default=no]
+- --enable-shared build shared libraries [default=yes]
+- --enable-static build static libraries [default=no]
+- --with-gnu-ld assume the C compiler uses GNU ld [default=no]
+- --without-index-ndx turn off .ndx index support
+- --without-index-ntx turn off .ntx index support
+- --without-memo-fields turn off memo fields support
+- --without-expressions turn off expressions support
+- --without-xbase-locking turn off XBase file locking
+- --without-realdelete turn off XBase record deletion
+- --without-xbase-debug turn off XBase specific debug
+- --without-largefile-support turn off XBase largefile support
+-
+-Once configured, execute make as follows to build the library:
+-
+- make
+-
+-Once compiled (and assuming no errors occurred), use make to install the
+-library, header files, and utilities as follows:
+-
+- make install
+-
+-The default install directory is /usr/local.
+-
+-
+-BUILDING THE LIBRARY ON WINDOWS
+--------------------------------
+-
+-The MINGW32 and CYGWIN compiler support didn't make the first cut to
+-Xbase64. They will be migrated forward in a future release of xbase64.
+-Any volunteers?
+-
+-If using the MINGW32 GCC compiler package, use the makefile.g95 make files.
+-Edit bin/makefile.g95 xbase/makefile.g95 to change installation directories.
+-
+-If using the CYGWIN environment, use the makefile.cyg make files (or fix
+-the autoconf/automake stuff to work correclty). However, for some reason
+-(as yet undetermined) it seems to run very slowly when compiled with the
+-cygwin compiler (perhaps the file handing in the cygwin dll is just dog slow?).
+-
+-
+-BUILDING THE LIRARY WITH BORLAND 5.5
+-------------------------------------
+-
+-There are batch files MAKEBCC.BAT which build the xbase libs for
+-Borland C++ 5.5.
+-
+-
+-
+-DOCUMENTATION
+--------------
+-
+-The documentation at this point consists of the original xBase documentation
+-(in the html directory). It is still very useful as little has changed
+-from the original library except bugfixes and a few enhancements.
+-
+-We are working on incorporating comments into the source to allow
+-generation of reference documentation using the Doxygen document generator.
+-A small amount has been done already, but we hope to complete this effort
+-before the next release.
+-
+-
+-CONTACT
+--------
+-
+-Please email comments, bug reports, and patches to Gary Kunkel
+-xdb-dev@lists.sourceforge.net
+-
+-
+Index: b/configure.in
+===================================================================
+--- a/configure.in
++++ b/configure.in
+@@ -74,7 +74,7 @@
+
+ # get G++ version
+ if test "$GXX" = "yes"; then
+- GXXVER=`${CXX} -v 2>&1 | grep version | cut -d " " -f 3 -`
++ GXXVER=`${CXX} -v 2>&1 | grep '^gcc version' | cut -d " " -f 3 -`
+ GXXVER="gcc${GXXVER}"
+ else
+ GXXVER=""