summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 10 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 517a4c8..c52f106 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,9 +11,18 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
+#
+# Test for gcc-6 support
+#
+#export CC=gcc-6
+#export CXX=g++-6
+
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-confflags = --prefix=/usr --mandir=\$${prefix}/share/man --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) --enable-static $(shell dpkg-buildflags --export=cmdline)
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+export CXXFLAGS+= -std=c++98
+
+confflags = --prefix=/usr --mandir=\$${prefix}/share/man --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) --enable-static
%:
dh $@ --with autoreconf