summaryrefslogtreecommitdiff
path: root/libcutl/cutl/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2014-07-23 15:25:44 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2014-07-23 15:25:44 +0200
commit8286ac511144e4f17d34eac9affb97e50646344a (patch)
treef1af7320d7b6be6be059216d0ad08ac7b4f73fd0 /libcutl/cutl/Makefile.am
parenta15cf65c44d5c224169c32ef5495b68c758134b7 (diff)
Imported Upstream version 4.0.0upstream/4.0.0
Diffstat (limited to 'libcutl/cutl/Makefile.am')
-rw-r--r--libcutl/cutl/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/libcutl/cutl/Makefile.am b/libcutl/cutl/Makefile.am
new file mode 100644
index 0000000..a7eead6
--- /dev/null
+++ b/libcutl/cutl/Makefile.am
@@ -0,0 +1,28 @@
+# file : cutl/Makefile.am
+# copyright : Copyright (c) 2009-2013 Code Synthesis Tools CC
+# license : MIT; see accompanying LICENSE file
+
+EXTRA_DIST = __file__(extra_dist)
+
+cutlincludedir = $(includedir)/cutl
+
+lib_LTLIBRARIES = libcutl.la
+libcutl_la_SOURCES = __path__(sources)
+
+nobase_cutlinclude_HEADERS = __path__(headers)
+nobase_nodist_cutlinclude_HEADERS = details/config.h
+
+if !LIBCUTL_EXTERNAL_BOOST
+libcutl_la_SOURCES += __path__(boost_sources)
+endif
+
+if !LIBCUTL_EXTERNAL_EXPAT
+libcutl_la_SOURCES += __path__(expat_sources)
+nobase_cutlinclude_HEADERS += __path__(expat_headers)
+endif
+
+libcutl_la_SOURCES += __path__(genx_sources)
+nobase_cutlinclude_HEADERS += __path__(genx_headers)
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) -DLIBCUTL_DYNAMIC_LIB
+AM_LDFLAGS = -release __value__(interface_version) -no-undefined