summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 2 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 7c5d89a..60d5392 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,12 +10,12 @@
#export DH_VERBOSE=1
export DH_OPTIONS
-derives_from_ubuntu := $(shell (dpkg-vendor --derives-from Ubuntu && echo "yes") || echo "no")
-
#
# Hardening
#
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
%:
@@ -36,7 +36,5 @@ override_dh_auto_install:
override_dh_install:
dh_install
-ifeq ($(derives_from_ubuntu),yes)
install -D -m 644 debian/ubuntu/apport-hook.py $(CURDIR)/debian/xsdcxx/usr/share/apport/package-hooks/source_xsdcxx.py
-endif