summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 1649d46..a3031ce 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,9 @@
#export DH_VERBOSE=1
export DH_OPTIONS
+DPKG_EXPORT_BUILDTOOLS=1
+include /usr/share/dpkg/buildtools.mk
+
#
# Hardening
#
@@ -18,7 +21,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export verbose=1
%:
- dh $@ --with autotools-dev --parallel
+ dh $@
override_dh_clean:
rm -f $(CURDIR)/libcult/build/system/configuration-dynamic.make
@@ -36,3 +39,7 @@ override_dh_auto_install:
override_dh_install:
dh_install
install -D -m 644 debian/ubuntu/apport-hook.py $(CURDIR)/debian/xsdcxx/usr/share/apport/package-hooks/source_xsdcxx.py
+
+override_dh_link:
+ jdupes -rl debian/xsdcxx/usr
+ dh_link