summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules59
1 files changed, 59 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8f52fc4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,59 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+export DH_OPTIONS
+
+
+#
+# path for bigendian
+#
+ORGUTF:=$(CURDIR)/xsd/tests/cxx/tree/encoding/char/utf-8/test.std
+NEWUTF:=$(CURDIR)/debian/bigendian/char/utf-8/test.std
+ORGWCHAR:=$(CURDIR)/xsd/tests/cxx/tree/encoding/wchar/test.std
+NEWWCHAR:=$(CURDIR)/debian/bigendian/wchar/test.std
+
+#
+# Hardening
+#
+export DEB_BUILD_HARDENING=1
+
+include /usr/share/dpkg/buildflags.mk
+CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS:=$(shell dpkg-buildflags --get CFLAGS) $(CPPFLAGS)
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS) $(CPPFLAGS)
+LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ rm -f $(ORGUTF).old
+ rm -f $(ORGWCHAR).old
+ mv $(ORGUTF) $(ORUTF).old
+ mv $(ORGWCHAR) $(ORGWCHAR).old
+ cp $(NEWUTF) $(ORGUTF)
+ cp $(NEWWCHAR) $(ORGWCHAR)
+ dh_auto_build
+
+override_dh_clean:
+ rm -f $(CURDIR)/libcult/build/system/configuration-dynamic.make
+ if test -e "$(ORGUTF).old"; then rm -f $(ORGUTF); mv $(ORGUTF).old $(ORGUTF); fi
+ if test -e "$(ORGWCHAR).old"; then rm -f $(ORGWCHAR); mv $(ORGWCHAR).old $(ORGWCHAR); fi
+ rmdir --ignore-fail-on-non-empty $(CURDIR)/libcult/build/system
+ dh_clean
+
+override_dh_auto_install:
+ MAKEFLAGS="$$MAKEFLAGS install_prefix=$(CURDIR)/debian/xsdcxx/usr" $(MAKE) -C $(CURDIR)/ -f makefile install
+ mv $(CURDIR)/debian/xsdcxx/usr/share/doc/xsd $(CURDIR)/debian/xsdcxx/usr/share/doc/xsdcxx
+ mv $(CURDIR)/debian/xsdcxx/usr/bin/xsd $(CURDIR)/debian/xsdcxx/usr/bin/xsdcxx
+ mv $(CURDIR)/debian/xsdcxx/usr/share/man/man1/xsd.1 $(CURDIR)/debian/xsdcxx/usr/share/man/man1/xsdcxx.1
+ rm -rf $(CURDIR)/debian/xsdcxx/usr/share/doc/libxsd
+ find $(CURDIR)/debian/xsdcxx \( -name "COPYRIGHT*" -o -name "FLOSSE*" -o -name "LICENSE*" -o -name "GPL*" \) -exec rm -v {} \;