summaryrefslogtreecommitdiff
path: root/distribution/posix/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-28 16:52:56 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-28 16:52:56 +0100
commit7b358424ebad9349421acd533c2fa1cbf6cf3e3e (patch)
tree686678532eefed525c242fd214d0cfb2914726c5 /distribution/posix/CMakeLists.txt
Initial import of xtrkcad version 1:4.0.2-2
Diffstat (limited to 'distribution/posix/CMakeLists.txt')
-rw-r--r--distribution/posix/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/distribution/posix/CMakeLists.txt b/distribution/posix/CMakeLists.txt
new file mode 100644
index 0000000..daa89cf
--- /dev/null
+++ b/distribution/posix/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Setup packaging ...
+SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "XTrackCAD is a CAD program for designing model railroad layouts.")
+SET(CPACK_GENERATOR "TGZ" "RPM" "TBZ2")
+SET(CPACK_PACKAGE_RELEASE 1)
+SET(CPACK_RPM_PACKAGE_LICENSE "GPL")
+SET(CPACK_RPM_PACKAGE_GROUP "Applications/Engineering")
+SET(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}////xtrkcad-desc.txt")
+SET(CPACK_PACKAGE_FILE_NAME "xtrkcad-setup-${XTRKCAD_VERSION}-${CPACK_PACKAGE_RELEASE}.${CMAKE_SYSTEM_PROCESSOR}")
+SET(CPACK_INSTALL_PREFIX "/usr/local/" )
+SET(CPACK_PACKAGE_VENDOR "XTrackCAD Fork Project")
+SET(CPACK_RPM_PACKAGE_REQUIRES "glibc gtk2 webkitgtk")
+# exclude these directories from the rpm
+SET(CPACK_RPM_EXCLUDE_FROM_AUTO_FILELIST_ADDITION "/usr/share/locale"
+ "/usr/share/locale/*"
+)
+
+SET(CPACK_RPM_CHANGELOG_FILE "${CMAKE_CURRENT_SOURCE_DIR}////changelog.txt")
+
+INCLUDE(CPack)
+