summaryrefslogtreecommitdiff
path: root/app/tools/halibut/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/tools/halibut/CMakeLists.txt')
-rw-r--r--app/tools/halibut/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/app/tools/halibut/CMakeLists.txt b/app/tools/halibut/CMakeLists.txt
new file mode 100644
index 0000000..ec7d74b
--- /dev/null
+++ b/app/tools/halibut/CMakeLists.txt
@@ -0,0 +1,32 @@
+SET(SOURCES
+ biblio.c
+ bk_html.c
+ contents.c
+ deflate.c
+ error.c
+ halibut.h
+ help.c
+ index.c
+ input.c
+ in_pf.c
+ in_afm.c
+ psdata.c
+ bk_paper.c
+ keywords.c
+ licence.c
+ main.c
+ malloc.c
+ misc.c
+ tree234.c
+ tree234.h
+ ustring.c
+ version.c
+ wcwidth.c
+ )
+
+INCLUDE_DIRECTORIES(charset)
+ADD_EXECUTABLE(halibut ${SOURCES})
+TARGET_LINK_LIBRARIES(halibut xtrkcad-charset)
+
+ADD_SUBDIRECTORY(charset)
+