summaryrefslogtreecommitdiff
path: root/windows/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'windows/CMakeLists.txt')
-rw-r--r--windows/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/windows/CMakeLists.txt b/windows/CMakeLists.txt
new file mode 100644
index 0000000..ed59211
--- /dev/null
+++ b/windows/CMakeLists.txt
@@ -0,0 +1,8 @@
+
+add_executable(testc_windows testc.c)
+target_link_libraries(testc_windows onig)
+if(NOT MSVC)
+ target_compile_options(testc_windows
+ PRIVATE -finput-charset=cp932 -fexec-charset=cp932
+ )
+endif(NOT MSVC)