summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAntoine Beaupré <anarcat@debian.org>2018-07-30 10:50:17 -0400
committerAntoine Beaupré <anarcat@debian.org>2018-07-30 10:50:17 -0400
commitbaec34cc51c5822c002b22072a9e99d662dce465 (patch)
tree4398591203334f0a028d2395786e3717d9e38e1d /setup.py
parent0a297829eaf3912c939e1b43a3ef6ddeb7607b38 (diff)
New upstream version 0.9.10upstream/0.9.10
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 9 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index b65fc23..e056c4f 100644
--- a/setup.py
+++ b/setup.py
@@ -342,15 +342,19 @@ setup(
'arrow',
'python-dateutil',
'colorlog',
- 'pyprind',
'rawkit',
'easygui',
- 'colour',
'pymediainfo',
'sortedcontainers',
- 'tornado'
+ 'tornado',
+ 'scandir;python_version<"3.5"',
+ 'typing;python_version<"3.5"',
+ 'PyGObject'
],
- extras_require={':python_version == "3.4"': ['scandir', 'typing']},
+ extras_require={
+ 'color_ouput': ['colour',],
+ 'progress_bar': ['pyprind',]
+ },
include_package_data = False,
data_files = [
(
@@ -388,6 +392,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Topic :: Multimedia :: Graphics',
'Topic :: Multimedia :: Video'
],