summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 9 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index b65fc23..e056c4f 100644
--- a/setup.py
+++ b/setup.py
@@ -342,15 +342,19 @@ setup(
'arrow',
'python-dateutil',
'colorlog',
- 'pyprind',
'rawkit',
'easygui',
- 'colour',
'pymediainfo',
'sortedcontainers',
- 'tornado'
+ 'tornado',
+ 'scandir;python_version<"3.5"',
+ 'typing;python_version<"3.5"',
+ 'PyGObject'
],
- extras_require={':python_version == "3.4"': ['scandir', 'typing']},
+ extras_require={
+ 'color_ouput': ['colour',],
+ 'progress_bar': ['pyprind',]
+ },
include_package_data = False,
data_files = [
(
@@ -388,6 +392,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Topic :: Multimedia :: Graphics',
'Topic :: Multimedia :: Video'
],