summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2021-11-28 13:38:33 +0100
committerJörg Frings-Fürst <debian@jff.email>2021-11-28 13:38:33 +0100
commitf017d0e96d22cf8b70ec67cdaf818e62d8902b67 (patch)
tree3c9f675d395735f43dd08deae45dd0fd8b4dcf88 /debian/rules
parent55d274a13c2524d55e07f2395316aa9d2cae912b (diff)
parentfd6e3971137d303c4c74bd7f63a3016bb87cc178 (diff)
Merge branch 'release/debian/0.30.14-2'debian/0.30.14-2
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 8eaecd6..a772218 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,9 +4,19 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
+#Enable the apport option when building of Ubuntu
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes)
+ APPORT = -Dinstall-apport-hook=true
+endif
+
%:
dh $@ --buildsystem=meson --with gnome
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --libexec=/usr/libexec \
+ -Dunity-support=true $(APPORT)
+
override_dh_gnome_clean:
dh_gnome_clean --no-control